Pop Sequence 02-线性结构4. Pop Sequence(25) (C++)浙大数据结构新手向

原题:
02-线性结构4 Pop Sequence(25 分)
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO

题意:根据所给的数组判断当一个堆栈从1,2...开始push,随时都能pop数字,最终pop的顺序能否构成题中所给的顺序

输入:第一行:M(stack最多能存储的数据)N(每次给N个数字组成的数组)K(共有N行数组)

输出:每行所给顺序是否能通过stack pop所得,输出YES/NO

思路:构建一个堆栈,函数只需要三个,分别是stack的push,pop以及检查能否输出数组。

检查函数stk_check中,在堆栈未放满并且数组没到最后一位的情况下,只要top的data不是目前待pop的第一位,则保持push下一位(直到top的data恰好是待pop的第一位,将其pop出来,继续检查新的top和新的待pop是否相等,不相等继续push)

循环结束后检查是否是完美情况:top标为-1 并输入的数组下标达到了最后一位,是则输出YES,其他均NO

#include <iostream>
#define Maxsize 1000
using namespace std;

struct Stk{
    int capa; //capacity of stack
    int top;  //top index
    int data[Maxsize]; // array to storage puch number
};

Stk * stk_creat(){   //creat stack
    Stk * tmp = new Stk;
    tmp->top = -1;
    tmp->capa = Maxsize;
    return tmp;
}

void stk_puch(Stk *ts, int ele){ // push of stack
    if (ts->top == ts->capa-1)
        cout << "Fill !"<<endl;
    else {
        ts->top++;
        ts->data[ts->top] = ele;
    }
}

void stk_pop(Stk *ts){  // pop of stack
    if (ts->top == -1)
        cout << "empty" <<endl;
    else
        ts->top--;
}

void stk_check(int st[],int new_capa,int n){ //check if array you input is ok
    Stk *ts = stk_creat(); //stack
    int idx=0; //the index of input array
    int ele=1; //the data to push in stack
    
    while(ts->top<new_capa-1 and idx<n){
        stk_puch(ts,ele++);
        while(ts->data[ts->top]==st[idx]){ //any time you can pop the right number then pop it
            stk_pop(ts);
            idx++;
        }
    }
    if(ts->top == -1 and idx==n) // judge if OK
        cout << "YES" << endl;
    else
        cout <<"NO"<<endl;
}

int main(){ //
    int m,n,k,ary[Maxsize];
    cin >>m>>n>>k;
    while(k--){
        for(int i=0;i<n;i++)
            cin >> ary[i];
        stk_check(ary,m,n);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值