括号配对问题
时间限制:
3000 ms | 内存限制:
65535 KB
难度:
3
-
描述
-
现在,有一行括号序列,请你检查这行括号是否配对。
-
输入
- 第一行输入一个数N(0<N<=100),表示有N组测试数据。后面的N行输入多组输入数据,每组输入数据都是一个字符串S(S的长度小于10000,且S不是空串),测试数据组数少于5组。数据保证S中只含有"[", "]", "(", ")" 四种字符 输出
- 每组输入数据的输出占一行,如果该字符串中所含的括号是配对的,则输出Yes,如果不配对则输出No 样例输入
-
3 [(]) (]) ([[]()])
样例输出
-
No No Yes
简单的栈
代码如下:
01.
#include <stdio.h>
02.
#include <string.h>
03.
#include <algorithm>
04.
#include <math.h>
05.
using
namespace
std;
06.
int
main()
07.
{
08.
int
t;
09.
scanf
(
"%d"
,&t);
10.
while
(t--)
11.
{
12.
int
a[10005]={0};
13.
char
s[10005];
14.
scanf
(
"%s"
,s);
15.
int
l=
strlen
(s);
16.
int
ADC=0;
17.
int
dps=1;
18.
for
(
int
i=0;i<l;i++)
19.
{
20.
if
(s[i]==
'('
||s[i]==
'['
)
21.
a[ADC++]=s[i];
22.
if
((s[i]==
')'
&&a[--ADC]!=
'('
)||(s[i]==
']'
&&a[--ADC]!=
'['
))
23.
{
24.
dps=0;
25.
break
;
26.
}
27.
}
28.
if
(dps)
29.
printf
(
"Yes\n"
);
30.
else
31.
printf
(
"No\n"
);
32.
}
33.
return
0;
34.
}