武汉科技大学计算机学院11月月赛:Draw Something

Draw Something

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
Wangpeng is good at drawing. Now he wants to say numbers like “521” to his girlfriend through the game draw something. Wangpeng can’t write the digit directly. So he comes up a way that drawing several squares and the total area of squares is the number he wants to say. Input all the square Wangpeng draws, what’s the number in the picture?

Input
  
  
There are multiple test cases. For each case, the first line contains one integer N(1≤N≤100) indicating the number of squares. Second line contains N integers ai(1≤ai≤100)represent the side length of each square. No squares will overlap. Input ends with N = 0.

Output
  
  
For each case, output the total area in one line.

Sample Input
  
  
4 1 2 3 4 3 3 3 3 0

Sample Output
  
  

30 27

 

 

题目又臭又长,其实就是n个数的平方和。

 

 

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
using namespace std;


int main()
{
    int i,n,sum,t;
    while(cin>>n,n)
    {
        sum=0;
        for(i=0;i<n;i++)
        {
            cin>>t;
            sum+=t*t;
        }
        cout<<sum<<endl;
    }

    return 520;
}


 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值