hdu 5818 Joint Stacks (模拟)

15 篇文章 0 订阅

Joint Stacks

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 154    Accepted Submission(s): 50


Problem Description
A stack is a data structure in which all insertions and deletions of entries are made at one end, called the "top" of the stack. The last entry which is inserted is the first one that will be removed. In another word, the operations perform in a Last-In-First-Out (LIFO) manner.
A mergeable stack is a stack with "merge" operation. There are three kinds of operation as follows:

- push A x: insert x into stack A
- pop A: remove the top element of stack A
- merge A B: merge stack A and B

After an operation "merge A B", stack A will obtain all elements that A and B contained before, and B will become empty. The elements in the new stack are rearranged according to the time when they were pushed, just like repeating their "push" operations in one stack. See the sample input/output for further explanation.
Given two mergeable stacks A and B, implement operations mentioned above.
 

Input
There are multiple test cases. For each case, the first line contains an integer  N(0<N105) , indicating the number of operations. The next N lines, each contain an instruction "push", "pop" or "merge". The elements of stacks are 32-bit integers. Both A and B are empty initially, and it is guaranteed that "pop" operation would not be performed to an empty stack. N = 0 indicates the end of input.
 

Output
For each case, print a line "Case #t:", where t is the case number (starting from 1). For each "pop" operation, output the element that is popped, in a single line.
 

Sample Input
  
  
4 push A 1 push A 2 pop A pop A 9 push A 0 push A 1 push B 3 pop A push A 2 merge A B pop A pop A pop A 9 push A 0 push A 1 push B 3 pop A push A 2 merge B A pop B pop B pop B 0
 

Sample Output
  
  
Case #1: 2 1 Case #2: 1 2 3 0 Case #3: 1 2 3 0
 

用链表模拟栈  

合并的时候保留 A B之中最大位置的尾指针 并且把该位置标记下

之后的 PUSH 照常 

POP的时候注意下是否有标记 没有就照常 

有的话 把尾指针的位置减一  标记位置往前推

还有 ARR中POP掉的位置 记为 -1 在有标记的POP的时候注意下


#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cctype>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<set>
#include<map>
#include<queue>
#include<cmath>
#include<bitset>
#define pi acos(-1.0)
#define inf 1<<29
#define INF 0x3fffffff
#define zero 1e-8

const int li[] = { -1, 0, 1, 0};
const int lj[] = {0, -1, 0, 1};

using namespace std;

const int N = 100000 + 107;

int arr[N], from[N];
bool flag[N];

int pointa, pointb, cnt;
string str1 = "push", str2 = "pop", str3 = "merge";

void init()
{
    memset(flag,0,sizeof(flag));
    memset(from, -1, sizeof(from));
    cnt = 0;
    pointa = pointb = 0;
}
int n;

int main()
{
    int c=1;
    while (~scanf("%d", &n) && n) {
        init();
        printf("Case #%d:\n",c++);
        for (int i = 0; i < n; ++i) {
            char l[10], r[10];
            scanf("%s%s", l, r);
            if (l == str1) {
                int num;
                scanf("%d", &num);
                arr[++cnt] = num;
                if (r[0] == 'A') {
                    from[cnt] = pointa;
                    pointa = cnt;
                 
                } else {
                    from[cnt] = pointb;
                    pointb = cnt;
               
                }
            }
            if (l == str2) {
                if (r[0]=='A'){
                        int tip=0;
                    while (1){
                        if (!flag[pointa]) break;
                        if (flag[pointa]&&arr[pointa]!=-1) {
                                tip=1;
                                break;
                        }
                        pointa--;
                        flag[pointa]=1;
                    }

                    printf("%d\n", arr[pointa]);
                    arr[pointa]=-1;
                    if (!tip)
                    pointa = from[pointa];
                    else {
                        pointa--;
                        flag[pointa]=1;
                    }

                }else {
                      int tip=0;
                    while (1){
                        if (!flag[pointb]) break;
                        if (flag[pointb]&&arr[pointb]!=-1) {
                                tip=1;

                                break;
                        }
                        pointb--;
                        flag[pointb]=1;
                    }

                    printf("%d\n", arr[pointb]);
                    arr[pointb]=-1;
                    if (!tip)
                    pointb = from[pointb];
                    else {
                        pointb--;
                        flag[pointb]=1;
                    }

                }
            }
            if (l == str3) {
                char m[10];
                scanf("%s", m);
                if (r[0] == m[0]) continue;
                int maxx=pointa>pointb?pointa:pointb;
                flag[maxx]=true;
                if (r[0] == 'A') {
                    pointa=maxx;
                    pointb=0;
                } else {
                    pointb=maxx;
                    pointa=0;
                }
            }
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值