绝对值排序
Problem Description
输入n(n<=100)个整数,按照绝对值从大到小排序后输出。题目保证对于每一个测试实例,所有的数的绝对值都不相等。
Input
输入数据有多组,每组占一行,每行的第一个数字为n,接着是n个整数,n=0表示输入数据的结束,不做处理。
Output
对于每个测试实例,输出排序后的结果,两个数之间用一个空格隔开。每个测试实例占一行。
Sample Input
3 3 -4 2
4 0 1 2 -3
0
Sample Output
-4 3 2
-3 2 1 0
#include <stdio.h>
#include <math.h>
int main() {
int n;
int x,y;
int a[100];
while(scanf("%d",&n) != EOF){
int t = 0;
int z = 0; //控制空格的输出
if(n == 0){
break;
}
else{
for(x = 0;x < n;x++){
scanf("%d",&a[x]);
}
for(x = 0;x < n;x++){
for(y = x + 1;y < n;y++){
if(abs(a[x]) < abs(a[y])){
t = a[y];
a[y] = a[x];
a[x] = t;
}
}
if(z > 0){
printf(" ");
}
z++;
printf("%d",a[x]);
}
printf("\n");
}
}
return -1;
}