HDU1005

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).


Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.


Output

For each test case, print the value of f(n) on a single line.


Sample Input

1 1 3

1 2 10

0 0 0

Sample Output

2

5



由于mod7,所以所有的数都是0~6这7个数的一个,那么对于f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7,f[n-1]和f[n-2]的这两个数的组合一共有7*7=49可能(就是两个数字的组合,每个数有7种可能,比如0和1,6和5,4和2),那么如果f[i-1]和f[i-2]的值为m和n,继续算下去,在49次运算之内,肯定会出现f[j-1]和f[j-2]的值为m和n,那么再之后,f[j]和f[i]的值肯定相等了,f[j+1]和f[i+1]也是相等的...

一句话,这种题肯定是有循环节存在的,不确定是49也没事,比如在500内找,这范围肯定够了.

另外要注意的就是循环不一定是从起始位置开始的,可能是从中间的某个位置i开始,到j为一个循环.


/*HDU1005 Number Sequence*/
#include <iostream>
using namespace std;

int main() {
	int a,b,n,t,start,i,j,tag;
	int f[50];
	while(cin>>a>>b>>n&&a!=0) {
		f[0]=1; f[1]=1; start=0; tag=0;
		for(j=2;j<50;j++) {
			f[j]=(a*f[j-1]+b*f[j-2])%7;
			for(i=j-1;i>0;i--) {
				if(f[j]==f[i]&&f[j-1]==f[i-1]) {
					t=j-i;
					start=i-1;
					tag=1;
					break;
				}
				if(tag) break;
			}
		}
		if(n-1<start) cout<<f[n-1]<<endl;
		else cout<<f[start+(n-1-start)%t]<<endl;
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值