HDU 1005 Number Sequence(周期性循环 AC题目)

Number Sequence

A number sequence is defined as follows
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7
Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

题意: 给出A , B, n, f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7, 求f(n)的值。
==这题如果暴力解决的话会超时,然后仔细观察的话,其实是又规律的,因为是对7取模,所以答案的可能值为0,1,2,3,4,5,6。一共7个数字,有7*7 = 49个组合,所以我们只需要算出前50个数字就可以了,大于50的对51取模。
AC代码

#include <stdio.h>

int f[55];
void init(int A, int B){
	f[1] = f[2] =1;
	for(int i = 3; i <= 50; i++){
		f[i] = (A * f[i - 1] + B * f[i - 2]) % 7;
	}
}
int main(){
	int n, a, b;
	while(scanf("%d %d %d", &a, &b, &n) && (a || b || n)){
		init(a, b);
		printf("%d\n", f[n % 51]);
	}
	return 0;
}

End

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值