POJ-2240 Arbitrage(最短路)


Arbitrage
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23825 Accepted: 10088

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No
题意: 几种货币中有没有经过几次兑换后使其自身到自身的汇率大于1的,就是任一货币通过其他货币到自身的最大

          最大汇率。

思路:用floyd算法求任意货币到其他货币的最大汇率,判断自身到自身是否大于1。

注意:在初始化时自身到自身应初始化为1,其他初始化为0,虽是Floyd算法但和普通的Floyd还有差别,汇率之间用            乘法而且要求最大路;还有字符串的处理,可选择map容器。

代码:

#include<stdio.h>
#include<string>
#include<map>
#include<iostream>
using namespace std;

int m,n;
double Map[50][50],x;//注意该doule型
char u[30],v[30];

void Floyd()
{
    int i,j,k;
    for( i=1 ; i<=n ; i++ )
        for( j=1 ; j<=n ; j++ )
            for( k=1 ; k<=n ; k++ )
            if( Map[i][j] < Map[i][k] * Map[k][j] )//最大汇率是小于,汇率之间用乘法
                Map[i][j] = Map[i][k] * Map[k][j] ;
}

int main()
{
    int q=1;
    while(scanf("%d",&n)&&n)
    {
        map<string,int>mi;//处理字符串
        int flag=0;

        for( int i=1 ; i<=n ; i++ )
        {
            for( int j=1 ; j<=n ; j++ )
            {
                if(i==j)
                    Map[i][j]=1;
                else
                    Map[i][j]=0;
            }
        }

        for( int i=1 ; i<=n ; i++ )//将每个地方标号
        {
            scanf("%s",u);
            mi[u]=i;
        }

        scanf("%d",&m);
        for( int i=1 ; i<=m ; i++ )
        {
            scanf("%s%lf%s",u,&x,v);
            Map[mi[u]][mi[v]]=x;
        }

        Floyd();

        for(int i=1 ; i<=n ; i++ )
        {
            if(Map[i][i]>1)//汇率增加
                flag=1;
        }
        printf("Case %d: ",q++);
        if(flag)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值