HDU-5655 CA Loves Stick(数学)

CA Loves Stick

                                                                          Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
                                                                                                  Total Submission(s): 2905    Accepted Submission(s): 809


Problem Description
CA loves to play with sticks.
One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.
(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
 

Input
First line contains  T  denoting the number of testcases.
T  testcases follow. Each testcase contains four integers  a,b,c,d  in a line, denoting the length of sticks.
1T1000, 0a,b,c,d2631
 

Output
For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).
 

Sample Input
  
  
2 1 1 1 1 1 1 9 2
 

Sample Output
  
  
Yes No
 

Source
 

Recommend
wange2014
 

Statistic |  Submit |  Discuss |  Not

题意:给边长分别为a,b,c,d的四条边,求能否构成四边形;

           构成四边形的条件 a,b,c,d从小到大排,a+b+c>d;

           但是题目中给的a,b,c,d太大三个相加可能超过long long 范围,所以就用d-b-c<a,解决;

代码:

#include<stdio.h>
#include<algorithm>
using namespace std;

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        __int64 a[5];
        int i,sum=0;
        for(i=0;i<4;i++)
            scanf("%I64d",&a[i]);
        sort(a,a+4);
        for(i=0;i<4;i++)
            if(a[i]==0)
                sum ++;
        if(sum!=0)
        {
            printf("No\n");
            continue;
        }
        if(a[3] - a[1] - a[2] < a[0] )
           printf("Yes\n");
        else
           printf("No\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值