HDU-1242 Rescue( 广搜 + 优先队列)

Rescue

                                                                            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                                 Total Submission(s): 32090    Accepted Submission(s): 11214


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

Author
CHEN, Xue
 

Source
 

Recommend
Eddy
 

Statistic |  Submit |  Discuss |  Note
题意:从r到a的最短时间,如果路上经过X花费时间为2,经过其他地方花费时间为1。

思路:最短路径广搜了,但是这个图的路上的不同地方权值不同有的为2,有的为1,所以需要优先队列,

           时间少的先入队;

这道题的测试数据有点水,一般的广搜也可以过,测试一下

6 2
a.
x.
x.
x.
x.
r.

这组数据!!!微笑

代码:

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;

struct node
{
    int x;
    int y;
    int step;
    friend bool operator<(node a,node b)
    {
        return a.step>b.step;
    }
};

char Map[205][205];
int book[203][203];
int dir[4][2]= {1,0,0,-1,-1,0,0,1};
int m,n,ex,ey,sx,sy,flag,sum;

int bfs(int x,int y)
{
    node now,tmp;
    priority_queue<node> q;
    now.x=x;
    now.y=y;
    now.step=0;
    book[x][y]=1;
    q.push(now);//入队
    while(!q.empty())
    {
        now=q.top();
        q.pop();
        if(now.x==ex && now.y==ey)
        {
            return now.step;
        }
        for(int i=0; i<4; i++)//枚举4个方向
        {
            int tx=now.x+dir[i][0];
            int ty=now.y+dir[i][1];

            if(tx>=m || ty>=n || tx<0 || ty<0 || book[tx][ty]==1 ||Map[tx][ty]=='#')//越界或撞墙或到过
                continue;

            if(Map[tx][ty]=='x')//遇到x时间加2;
                tmp.step=now.step+2;
            else
                tmp.step=now.step+1;//否则加1;
            book[tx][ty]=1;
            tmp.x=tx;
            tmp.y=ty;
            q.push(tmp);//入队
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d%d",&m,&n))
    {
        for(int i=0; i<m; i++)
        {
            scanf("%s",Map[i]);
            for(int j=0; j<n; j++)
            {
                if(Map[i][j]=='r')
                {
                    sx=i;
                    sy=j;
                }
                if(Map[i][j]=='a')
                {
                    ex=i;
                    ey=j;
                }
            }
        }
        memset(book,0,sizeof(book));
        int s=bfs(sx,sy);
        if(s)
            printf("%d\n",s);
        else
            printf("Poor ANGEL has to stay in the prison all his life.\n");//营救失败!!!
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值