hdu1548-A strange lift BFS

1548

Sample Input
  
  
5 1 5 //5层楼 当前位置1楼 目标5楼 3 3 1 2 5 //1楼只可以按3,不能再下,到了4楼;4楼只能按2,到了2楼;2楼按3到了五楼 0
 

Sample Output
  
  
3 // 最少按了3次键

#include <iostream>    
#include <vector>
#include <queue>
using namespace std;    
int n,s,e;
int map[210],judge[210];
struct node
{
    int fl;
    int step;      //层数,步数
};
int bfs()
{
    queue<node> q;
    node pre,next;
    pre.fl = s;
    pre.step = 0;
    q.push(pre);
    judge[s] = 1;
    memset(judge,0,sizeof(judge));
    while (!q.empty())
    {
        pre = q.front();
        q.pop();
        if (pre.fl == e){
            return pre.step;
            break;    }
        for (int i = -1; i <= 1; i+=2)    
        {    
            next = pre;            //保持pre不动,只动next
            next.fl+=i*map[next.fl]; //map[next.fl]层数可以按的键
            if(next.fl>n || next.fl<1 || judge[next.fl] == 1){
                continue;}
            next.step++;
            q.push(next);
            judge[next.fl] = 1;
        }
    }
    return -1;
}
int main()
{
    while(cin>>n && n){
        cin>>s>>e;
        for (int i = 1; i <= n; i++)
            cin>>map[i]; 
        cout<<bfs()<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值