hdu 5818 Joint Stacks (优先队列)

Joint Stacks

 

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1834    Accepted Submission(s): 824

 

 

Problem Description

A stack is a data structure in which all insertions and deletions of entries are made at one end, called the "top" of the stack. The last entry which is inserted is the first one that will be removed. In another word, the operations perform in a Last-In-First-Out (LIFO) manner.
A mergeable stack is a stack with "merge" operation. There are three kinds of operation as follows:

- push A x: insert x into stack A
- pop A: remove the top element of stack A
- merge A B: merge stack A and B

After an operation "merge A B", stack A will obtain all elements that A and B contained before, and B will become empty. The elements in the new stack are rearranged according to the time when they were pushed, just like repeating their "push" operations in one stack. See the sample input/output for further explanation.
Given two mergeable stacks A and B, implement operations mentioned above.

 

 

Input

There are multiple test cases. For each case, the first line contains an integer N(0<N≤105), indicating the number of operations. The next N lines, each contain an instruction "push", "pop" or "merge". The elements of stacks are 32-bit integers. Both A and B are empty initially, and it is guaranteed that "pop" operation would not be performed to an empty stack. N = 0 indicates the end of input.

 

 

Output

For each case, print a line "Case #t:", where t is the case number (starting from 1). For each "pop" operation, output the element that is popped, in a single line.

 

 

Sample Input

 

4 push A 1 push A 2 pop A pop A 9 push A 0 push A 1 push B 3 pop A push A 2 merge A B pop A pop A pop A 9 push A 0 push A 1 push B 3 pop A push A 2 merge B A pop B pop B pop B 0

 

 

Sample Output

 

Case #1: 2 1 Case #2: 1 2 3 0 Case #3: 1 2 3 0

思路:这题可以用优先队列,前面一直是TLE,后来用一个flag来记录是从哪个队列push或者pop出,最后面把一个队列全部转移到另一个队列,其实可以直接把Q[1]的队列移到Q[0]中,然后用flag来记录应从哪个队列输出。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
using namespace std;
struct node
{
    int m,n;
    friend bool operator<(node a,node b)
    {
        return a.n<b.n;
    }
};
int main()
{
    int z=1;
    int n;
    char c[10];
    node a,b;
    char d,e;
    int f,j;
    while(~scanf("%d",&n)&&n)
    {
        printf("Case #%d:\n",z++);
        priority_queue<node>Q[2];
        int i;
        int js=1;
        int flag=0;
        while(n--)
        {
            scanf("%s",c);
            scanf(" %c",&d);
            if(strcmp(c,"push")==0)
            {
                scanf(" %d",&a.m);
                a.n=js++;
                if(d=='A')
                Q[flag].push(a);
                else Q[flag^1].push(a);
            }
            else if(strcmp(c,"pop")==0)
            {
                if(d=='A')
                {
                    a=Q[flag].top();
                    Q[flag].pop();
                }
                else
                {
                    a=Q[flag^1].top();
                    Q[flag^1].pop();
                }
                cout<<a.m<<endl;
            }
            else
            {
                scanf(" %c",&e);
                while(!Q[1].empty())
                {
                    Q[0].push(Q[1].top());
                    Q[1].pop();

                }
                if (d=='A'&&flag==1) flag=0;
                if (d=='B'&&flag==0) flag=1;
            }
        }
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值