poj2184

Cow Exhibition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13752 Accepted: 5581

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8


题意:告诉你n头牛的智商和幽默感,要求出智商之和与幽默感之和的和的最大值,其中这两个和都不能为负。


思路:其实这和01背包的思想一样,可以把智商当做费用,幽默感当做价值,因为可能是负的,而数组下标不能为负,我们就可以定义小于10000的wei负,大于100000为正,然后按照01背包的来做,如果为正时就要从大往小的扫,负的时候反过来。


代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int inf=0x3f3f3f;
struct node
{
    int s,f;
}a[105];
int dp[212005];
int main()
{
   int n;
   while(cin>>n)
   {
       int i,j;
       for(i=0;i<n;i++)
       {
           scanf("%d%d",&a[i].s,&a[i].f);
       }
        for(i=0;i<=200000;i++)
            dp[i]=-inf;
        dp[100000]=0;
        for(i=0;i<n;i++)
        {
            if(a[i].s<0&&a[i].f<0)
                continue;
            if(a[i].s>0)
            {
                for(j=200000;j>=a[i].s;j--)//100000以上是智力和为正的时候  
                {
                    if(dp[j-a[i].s]>-inf)
                    dp[j]=max(dp[j-a[i].s]+a[i].f,dp[j]);
                }
            }
            else
            {
                for(j=a[i].s;j<=200000+a[i].s;j++)//100000一下是当智力和为负的时候 
                {
                    if(dp[j-a[i].s]>-inf)
                    dp[j]=max(dp[j-a[i].s]+a[i].f,dp[j]);
                }
            }
        }
        int ans=-inf;
        for(i=100000;i<=200000;i++)
        {
            if(dp[i]>=0)
            {
                ans=max(ans,dp[i]+i-100000);
            }
        }
        cout<<ans<<endl;
   }
   return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值