hdu1251

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 43822    Accepted Submission(s): 15705


Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
  
  
banana band bee absolute acm ba b band abc
 

Sample Output
  
  
2 3 1 0
 
思路:找出前缀出现的次数就可以了。

代码:
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;
typedef struct node
{
    int num;
    struct node*child[26];
}node,*Node;
Node root;
void insert(char *s)
{
    int i,j;
    int len=strlen(s);
    Node next=NULL,temp=NULL;
    if(len==0)return ;
    next=root;

    for(i=0;i<len;i++)
    {
        if(next->child[s[i]-'a']!=NULL)
        {
            next=next->child[s[i]-'a'];
            (next->num)++;
        }
        else
        {
            temp=(Node)calloc(1,sizeof(node));
            for(j=0;j<26;j++)
                temp->child[j]=0;
            next->child[s[i]-'a']=temp;
            next=temp;
            next->num=1;

        }
    }

}
int  search(char *s)
{
    int i;
    int len=strlen(s);
    Node next=NULL;

    if(len==0)return 0;
    next=root;
    for(i=0;i<len;i++)
    {
        if(next->child[s[i]-'a']!='\0')
        {
            next=next->child[s[i]-'a'];
        }
        else return 0;
    }
    return next->num;
}
void release(Node root)
{
    int i;
    if(NULL==root)
        return;
    for(i=0;i<26;i++)
    {
        if(root->child[i]!=NULL)
        {
            release(root->child[i]);
        }
    }
    free(root);
    root=NULL;
}
int main()
{
    char s[25];
    int i;
    root=(Node)calloc(1,sizeof(node));
    for(i=0;i<26;i++)
        root->child[i]=0;
    root->num=0;
    while(gets(s),strcmp(s,"")!=0)
        insert(s);
    while(gets(s)!=0)
        cout<<search(s)<<endl;
        release(root);
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值