poj3281Dining

Dining
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 20254 Accepted: 9009

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers:  NF, and  D 
Lines 2.. N+1: Each line  i starts with a two integers  Fi and  Di, the number of dishes that cow  i likes and the number of drinks that cow  i likes. The next  Fi integers denote the dishes that cow  i will eat, and the  Di integers following that denote the drinks that cow  i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3
题意:有N头牛,F种食物可以制作,D种饮料可以制作  然后每行代表一头牛的喜好,开头两个数fi,di表示这头牛喜欢fi种食物,di种饮料,接下来fi个数表示喜欢的食物编号,di个数表示喜欢的饮料的编号 现在主人使用最优决策制作出F种食物和D种饮料,问怎么喂才能使尽可能多的牛喂饱(喂饱=一份食物一份饮料,且一头牛最多消耗一份食物和一份饮料) 输出最多喂饱的牛数 
思路:将0作为超级源点,N*2+f+d+1作为超级汇点,N*2+1到N*2+f作为食物的点,N*2+f+1到N*2+f+d作为饮料的点,然后人拆为1-2*N,容量都为1,然后建图,求最大流。
代码:
#include<iostream>
#include<stdio.h>
#include<string.h>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;
const int inf=200000+10;
const int maxn=410;
const int maxm=200000+100;
int n,f,d;
int s,t;
int head[maxn];
int Next[maxm];
int depth[maxn];
int cnt;
struct node
{
    int u,v,w;
}e[maxm];
void addedge(int u,int v,int w)
{
    cnt++;
    Next[cnt]=head[u];
    head[u]=cnt;
    e[cnt].u=u;
    e[cnt].v=v;
    e[cnt].w=w;
    cnt++;
    Next[cnt]=head[v];
    head[v]=cnt;
    e[cnt].u=v;
    e[cnt].v=u;
    e[cnt].w=0;
}
int bfs()
{
    queue<int>q;
    memset(depth,-1,sizeof(depth));
    depth[s]=1;
    q.push(s);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        for(int i=head[u];i!=-1;i=Next[i])
        {
            int v=e[i].v;
            if((depth[v]==-1)&&(e[i].w>0))
            {
                depth[v]=depth[u]+1;
                q.push(v);
            }
        }
    }
    if(depth[t]==-1)
        return 0;
    return 1;
}
int dfs(int u,int w)
{
    if(u==t)
        return w;
    for(int i=head[u];i!=-1;i=Next[i])
    {
        int v=e[i].v;
        if((depth[v]==depth[u]+1)&&(e[i].w>0))
        {
            int d=dfs(v,min(w,e[i].w));
            if(d>0)
            {
                e[i].w-=d;
                e[i^1].w+=d;
                return d;
            }
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d%d%d",&n,&f,&d))
    {
        int i;
        cnt=-1;
        s=0;
        t=n*2+f+d+1;
        int x,y;
        memset(head,-1,sizeof(head));
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&x,&y);
            for(int j=0;j<x;j++)
            {
                int k;
                scanf("%d",&k);
                addedge(n*2+k,i,1);
            }
            for(int j=0;j<y;j++)
            {
                int k;
                scanf("%d",&k);
                addedge(n+i,n*2+f+k,1);
            }
            addedge(i,n+i,1);
        }
          for(i=1;i<=f;i++)
        {
            addedge(0,n*2+i,1);
        }
        for(i=1;i<=d;i++)
        {
            addedge(n*2+f+i,t,1);
        }
        int ans=0;
        while(bfs())
        {
            while(int ss=dfs(0,inf))
                ans+=ss;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值