poj1459Power Network

Power Network
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 29460 Accepted: 15278

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6
题意:有n个点,np个供电点,nc个消费点,m条线路,接来题目先给出的是m条线路的数据,(起点,终点)最多运载量,然后是np个供电点的数据(供电点)最多供电量,接着就是nc个消费点的数据(消费点)最多消费电量。 求出给定的图最大能消费的总电量
思路:定0和n+1为超级源点和汇点,然后求最大流就好了。
代码:
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <cmath>
#include <queue>
#include <vector>
using namespace std;
const int maxn=10010;
const int maxm=100010;
const int inf=0x3f3f3f3f;
int n,np,nc,m;
int s,t;
int cnt;
int Next[maxm];
int depth[maxn];
int head[maxn];
int cur[maxn];
struct edge{
    int u,v,w;
}e[maxm];
void addedge(int u,int v,int w)
{
    cnt++;
    Next[cnt]=head[u];
    head[u]=cnt;
    e[cnt].u=u;
    e[cnt].v=v;
    e[cnt].w=w;
    cnt++;
    Next[cnt]=head[v];
    head[v]=cnt;
    e[cnt].u=v;
    e[cnt].v=u;
    e[cnt].w=0;
}
int bfs()
{
    memset(depth,-1,sizeof(depth));
    depth[s]=1;
    queue<int>q;
    q.push(s);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        for(int i=head[u];i!=-1;i=Next[i])
        {
            int v=e[i].v;
            if(depth[v]==-1&&e[i].w>0)
            {
                depth[v]=depth[u]+1;
                q.push(v);
            }
        }
    }
    if(depth[t]==-1)return 0;
    return 1;
}
int dfs(int u,int w)
{
    if(u==t)
        return w;
    int f=0;
    for(int i=head[u];i!=-1;i=Next[i])
    {
        int v=e[i].v;
        if(depth[v]==depth[u]+1&&e[i].w>0)
        {
            int d=dfs(v,min(w-f,e[i].w));
            if(d>0)
            {
                e[i].w-=d;
                e[i^1].w+=d;
                f+=d;
                if(f==w)break;
            }
        }
    }
    if(!f)depth[u]=-2;
    return f;
}
int main()
{
    while(scanf("%d%d%d%d",&n,&np,&nc,&m)!=EOF)
    {
        int i;
        s=0;
        memset(head,-1,sizeof(head));
        cnt=-1;
        int a,b,c;
        char e;
        t=n+1;
       for(i=0;i<m;i++)
        {
              while(getchar()!='(');
              scanf("%d,%d)%d",&a,&b,&c);
              addedge(a+1,b+1,c);
        }
       for(i=0;i<np;i++)
        {
             while(getchar()!='(');
              scanf("%d)%d",&a,&c);
              addedge(0,a+1,c);
        }
       for(i=0;i<nc;i++)
        {
             while(getchar()!='(');
              scanf("%d)%d",&a,&c);
              addedge(a+1,t,c);
        }
        int ans=0;
        while(bfs())
        {
            for(i=0;i<n+3;i++)
            {
                cur[i]=head[i];
            }
            while(int di=dfs(0,inf))
                ans+=di;
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值