hdu3836Equivalent Sets

Equivalent Sets

Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 104857/104857 K (Java/Others)
Total Submission(s): 5277    Accepted Submission(s): 1916


Problem Description
To prove two sets A and B are equivalent, we can first prove A is a subset of B, and then prove B is a subset of A, so finally we got that these two sets are equivalent.
You are to prove N sets are equivalent, using the method above: in each step you can prove a set X is a subset of another set Y, and there are also some sets that are already proven to be subsets of some other sets.
Now you want to know the minimum steps needed to get the problem proved.
 

Input
The input file contains multiple test cases, in each case, the first line contains two integers N <= 20000 and M <= 50000.
Next M lines, each line contains two integers X, Y, means set X in a subset of set Y.
 

Output
For each case, output a single integer: the minimum steps needed.
 

Sample Input
      
      
4 0 3 2 1 2 1 3
 

Sample Output
      
      
4 2
思路:首先求出图的所有强连通分量,然后缩点成DAG图.求出新图中所有点的出度=0与入度=0的节点数大的即为所求需要添加的边.
代码:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <cmath>
using namespace std;
const int N=20000+10;
int dfn[N];
int low[N];
int belong[N];
int in[N];
int out[N];
bool instack[N];
stack<int>s;
int n,m;
int cnt,index;
vector<int>e[N];
void init()
{
    int i;
    for(i=0;i<=n;i++)
        e[i].clear();
    while(!s.empty())
        s.pop();
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
    memset(belong,0,sizeof(belong));
    memset(instack,false,sizeof(instack));
    index=cnt=0;
    memset(in,0,sizeof(in));
    memset(out,0,sizeof(out));
}
void tarjan(int u)
{
    dfn[u]=low[u]=++index;
    int i;
    instack[u]=true;
    s.push(u);
    int v;
    for(i=0;i<e[u].size();i++)
    {
        v=e[u][i];
        if(!dfn[v])
        {
            tarjan(v);
            low[u]=min(low[v],low[u]);
        }
        else if(instack[v])
            low[u]=min(dfn[v],low[u]);
    }
    if(dfn[u]==low[u])
    {
        cnt++;
        do
        {
            v=s.top();
            s.pop();
            belong[v]=cnt;
            instack[v]=false;
        }
        while(u!=v);
    }
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int i,j;
        init();
        int a,b;
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            e[a].push_back(b);
        }
        for(i=1;i<=n;i++)
        {
            if(!dfn[i])
                tarjan(i);
        }
        for(i=1;i<=n;i++)
        {
            for(j=0;j<e[i].size();j++)
            {
                if(belong[i]!=belong[e[i][j]])
                {
                    out[belong[i]]++;
                    in[belong[e[i][j]]]++;
                }
            }
        }
        int ans=0,ans1=0;
        for(i=1;i<=cnt;i++)
        {
            if(in[i]==0)ans++;
            if(out[i]==0)ans1++;
        }
        if(cnt==1)printf("0\n");
        else printf("%d\n",max(ans,ans1));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值