poj1438One-way Traffic

One-way Traffic
Time Limit: 10000MS Memory Limit: 10000K
Total Submissions: 969 Accepted: 313 Special Judge

Description

In a certain town there are n intersections connected by two- and one-way streets. The town is very modern so a lot of streets run through tunnels or viaducts. Of course it is possible to travel between any two intersections in both ways, i.e. it is possible to travel from an intersection a to an intersection b as well as from b to a without violating traffic rules. Because one-way streets are safer, it has been decided to create as much one-way traffic as possible. In order not to make too much confusion it has also been decided that the direction of traffic in already existing one-way streets should not be changed. 

Your job is to create a new traffic system in the town. You have to determine the direction of traffic for as many two-way streets as possible and make sure that it is still possible to travel both ways between any two intersections. 

Write a program that: 

> reads a description of the street system in the town from the standard input, 

> for each two-way street determines one direction of traffic or decides that the street must remain two-way, 

> writes the answer to the standard output. 

Input

The first line of the input contains two integers n and m, where 2 <= n <= 2000 and n-1 <= m <= n(n-1)/2. Integer n is the number of intersections in the town and interger m is the number of streets. 

Each of the next m lines contains three integers a, b and c, where 1 <= a <= n, 1 <= b <= n, a != b and c belongs to {1, 2}. If c = 1 then intersections a and b are connected by an one-way street from a to 
b. If c = 2 then intersections a and b are connected by a two-way street. There is at most one street 
connecting any two intersections. 

Process to the end of file. 

Output

The output contains exactly the same number of lines as the number of two-way streets in the input. 

For each such street (in any order) the program should write three integers a, b and c meaning, the new 
direction of the street from a to b (c = 1) or that the street connecting a and b remains two-way (c = 2). If there are more than one solution with maximal number of one-way streets then your program should 
output any of them but just one.

Sample Input

4 4
4 1 1
4 2 2
1 2 1
1 3 2

Sample Output

2 4 1
3 1 2
题意:改变尽量多的双向边,使得改变后的图还是强连通的
思路:运用tarjan缩点,割边需保持双向,其他单向就可以了。
代码:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <stack>
#include <vector>
using namespace std;
const int N=5000+50;
const int M=4000010;
int dfn[N],head[N],low[N],belong[N];
bool instack[N];
int in[N],out[N];
struct edge
{
    int u,v,next,cnt,d;
}e[M*2];
int n,m;
int cnt,num,index;
stack<int>s;
void addedge(int u,int v,int d)
{
    e[num].u=u;
    e[num].v=v;
    e[num].d=d;
    e[num].cnt=-1;
    e[num].next=head[u];
    head[u]=num++;
}
void init()
{
    memset(head,-1,sizeof(head));
    memset(low,0,sizeof(low));
    memset(dfn,0,sizeof(dfn));
    memset(in,0,sizeof(in));
    memset(out,0,sizeof(out));
    memset(belong,0,sizeof(belong));
    memset(instack,false,sizeof(instack));
    while(!s.empty())
        s.pop();
    cnt=index=num=0;
}
void tarjan(int u,int pre)
{
    dfn[u]=low[u]=++index;
    s.push(u);
    instack[u]=true;
    int v;
    for(int i=head[u];i!=-1;i=e[i].next)
    {
        v=e[i].v;
        if(v==pre)continue;
        if(e[i].cnt!=-1)continue;
        if(e[i].d==0)continue;
        e[i].cnt=1;
        e[i^1].cnt=0;
        if(!dfn[v])
        {
            tarjan(v,u);
            low[u]=min(low[u],low[v]);
            if(low[v]>dfn[u])
            {
                e[i^1].cnt=1;
            }
        }
        else if(instack[v])
        {
            low[u]=min(low[u],dfn[v]);
        }
    }
    if(dfn[u]==low[u])
    {
        cnt++;
        do{
            v=s.top();
            s.pop();
            belong[v]=cnt;
            instack[v]=false;
        }while(u!=v);
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        int i,j;
        init();
        int a,b,c;
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(c==2)
            {
                addedge(a,b,c);
                addedge(b,a,c);
            }
            else
            {
                addedge(a,b,c);
                addedge(b,a,0);
            }
        }
        for(i=1;i<=n;i++)
        {
            if(!dfn[i])
                tarjan(i,i);
        }
        for(i=0;i<num;i+=2)
        {
            if(e[i].d==2&&e[i].cnt==1&&e[i^1].cnt==1)
            {
                printf("%d %d 2\n",e[i].u,e[i].v);
            }
           else  if(e[i].d==2&&e[i].cnt==1&&e[i^1].cnt==0)
            {
                printf("%d %d 1\n",e[i].u,e[i].v);
            }
            else if(e[i].d==2&&e[i].cnt==0&&e[i^1].cnt==1)
            {
                printf("%d %d 1\n",e[i^1].u,e[i^1].v);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值