poj1470Closest Common Ancestors

Closest Common Ancestors
Time Limit: 2000MS Memory Limit: 10000K
Total Submissions: 21497 Accepted: 6817

Description

Write a program that takes as input a rooted tree and a list of pairs of vertices. For each pair (u,v) the program determines the closest common ancestor of u and v in the tree. The closest common ancestor of two nodes u and v is the node w that is an ancestor of both u and v and has the greatest depth in the tree. A node can be its own ancestor (for example in Figure 1 the ancestors of node 2 are 2 and 5)

Input

The data set, which is read from a the std input, starts with the tree description, in the form: 

nr_of_vertices 
vertex:(nr_of_successors) successor1 successor2 ... successorn 
...
where vertices are represented as integers from 1 to n ( n <= 900 ). The tree description is followed by a list of pairs of vertices, in the form: 
nr_of_pairs 
(u v) (x y) ... 

The input file contents several data sets (at least one). 
Note that white-spaces (tabs, spaces and line breaks) can be used freely in the input.

Output

For each common ancestor the program prints the ancestor and the number of pair for which it is an ancestor. The results are printed on the standard output on separate lines, in to the ascending order of the vertices, in the format: ancestor:times 
For example, for the following tree: 

Sample Input

5
5:(3) 1 4 2
1:(0)
4:(0)
2:(1) 3
3:(0)
6
(1 5) (1 4) (4 2)
      (2 3)
(1 3) (4 3)

Sample Output

2:1
5:5

思路:直接LCA模板即可。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <stack>
#include <vector>
using namespace std;
const int N=1100;
int head[N],f[N],in[N],q[N][N],a[N],vis[N];
int num,cnt;
int n,m;
struct node
{
    int u,v,next;
}e[N<<1];
int x,y;
int ans;
void init()
{
    memset(f,0,sizeof(f));
    memset(in,0,sizeof(in));
    memset(head,-1,sizeof(head));
    memset(q,0,sizeof(q));
    memset(vis,0,sizeof(vis));
    cnt=num=0;
}
void addedge(int u,int v)
{
    e[num].v=v;
    e[num].next=head[u];
    head[u]=num++;
}
int findx(int k)
{
    if(k==f[k])return k;
    return f[k]=findx(f[k]);
}
void dfs(int u)
{
    f[u]=u;
    for(int i=head[u];i!=-1;i=e[i].next)
    {
       int v=e[i].v;
       dfs(v);
       f[v]=u;
    }vis[u]=1;
    for(int i=1;i<=n;i++)
    {
        if(vis[i]&&q[u][i])
        {
            a[findx(i)]+=q[u][i];
        }
    }
}
int main()
{

    while(~scanf("%d",&n))
    {
        int i;
        init();
        memset(a,0,sizeof(a));
        int u,v,k;
        for(i=0;i<n;i++)
        {
              scanf("%d:(%d)",&u,&k);
              while(k--)
              {
                  scanf("%d",&v);
                  addedge(u,v);
                  in[v]++;
              }
        }
        scanf("%d",&m);
        while(m--)
        {
            scanf(" (%d %d)",&u,&v);
            q[u][v]++;
            q[v][u]++;
        }
        for(i=1;i<=n;i++)
        {
            if(in[i]==0)
            {
                dfs(i);
                break;
            }
        }
        for(i=1;i<=n;i++)
        {
            if(a[i])
            {
                printf("%d:%d\n",i,a[i]);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值