poj 2191Mersenne Composite Numbers(大整数因式分解+素数判断)

Mersenne Composite Numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2442 Accepted: 1139

Description

One of the world-wide cooperative computing tasks is the "Grand Internet Mersenne Prime Search" -- GIMPS -- striving to find ever-larger prime numbers by examining a particular category of such numbers. 
A Mersenne number is defined as a number of the form (2 p–1), where p is a prime number -- a number divisible only by one and itself. (A number that can be divided by numbers other than itself and one are called "composite" numbers, and each of these can be uniquely represented by the prime numbers that can be multiplied together to generate the composite number — referred to as its prime factors.) 
Initially it looks as though the Mersenne numbers are all primes. 
PrimeCorresponding Mersenne Number
24–1 = 3 -- prime
38–1 = 7 -- prime
532–1 = 31 -- prime
7128–1 = 127 -- prime

If, however, we are having a "Grand Internet" search, that must not be the case. 
Where k is an input parameter, compute all the Mersenne composite numbers less than 2 k -- where k <= 63 (that is, it will fit in a 64-bit signed integer on the computer). In Java, the "long" data type is a signed 64 bit integer. Under gcc and g++ (C and C++ in the programming contest environment), the "long long" data type is a signed 64 bit integer. 

Input

Input contains a single number, without leading or trailing blanks, giving the value of k. As promised, k <= 63.

Output

One line per Mersenne composite number giving first the prime factors (in increasing order) separate by asterisks, an equal sign, the Mersenne number itself, an equal sign, and then the explicit statement of the Mersenne number, as shown in the sample output. Use exactly this format. Note that all separating white space fields consist of one blank.

Sample Input

31

Sample Output

23 * 89 = 2047 = ( 2 ^ 11 ) - 1
47 * 178481 = 8388607 = ( 2 ^ 23 ) - 1
233 * 1103 * 2089 = 536870911 = ( 2 ^ 29 ) - 1

题意:i从1到k,如果是素数,看2的i次方减1是否为合数,如果是,看是否能拆成几个素数相乘。

思路:用大整数因式分解Pollard_rho算法和大整数素数判断miller_rabin。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <map>
using namespace std;
#define ll long long
bool prim[65];
int p[65];
int cnt;
ll yz[111111];
void init()
{
    memset(prim,true,sizeof(prim));
    cnt=0;
    for(int i=2;i<64;i++)
    {
        if(prim[i])
        {
            p[cnt++]=i;
            for(int j=i*2;j<64;j+=i)
                prim[j]=false;
        }
    }
}
ll mul(ll x,ll y,ll mod)
{
    ll ans=0;
    while(y)
    {
        if(y&1)ans=(ans+x)%mod;
        x=(x+x)%mod;
        y>>=1;
    }
    return ans;
}
ll poww(ll x,ll y,ll mod)
{
    ll ans=1;
    while(y)
    {
        if(y&1)ans=mul(ans,x,mod);
        x=mul(x,x,mod);
        y>>=1;
    }
    return ans;
}
bool miller_rabin(ll n)
{
    ll t,u,a,x,y;
    if(n==2)return true;
    if(n==1||!(n&1))return false;
    for(t=0,u=n-1;!(u&1);t++,u>>=1);
    for(int i=0;i<10;i++)
    {
        ll a=rand()%(n-1)+1;
        x=poww(a,u,n);
        for(int j=0;j<t;j++)
        {
            y=mul(x,x,n);
            if(y==1&&x!=1&&x!=n-1)
                return false;
            x=y;
        }
        if(x!=1)
            return false;
    }
    return true;
}
ll gcd(ll a,ll b)
{
   if(a<0)
        return gcd(-a,b);
        if(a==0)
            return 1;
    while(b)
    {
        long long int t=a%b;
        a=b;
        b=t;
    }
    return a;
}
int num;
ll Pollard_rho(ll n,ll c)
{
    int i=1,k=2;
    ll x=rand()%(n-1)+1;
    ll y=x;
    while(1)
    {
        i++;
        x=(mul(x,x,n)+c)%n;
        ll p=gcd(y-x,n);
        if(p!=1&&p!=n)
            return p;
        if(y==x)
            return n;
        if(i==k)
        {
            y=x;
            k+=k;
        }
    }
}
void findx(ll n)
{
    if(n==1)return;
    if(miller_rabin(n))
    {
        yz[num++]=n;
        //cout<<n<<endl;
        return ;
    }
    ll p=n;
    while(p>=n)
        p=Pollard_rho(p,rand()%(n-1)+1);
    findx(p);
    findx(n/p);
}
int main()
{
   init();
   int k;
   //ll z=2047;
  // findx(z);
   while(~scanf("%d",&k))
   {
        for(int i=0;i<cnt;i++)
        {

            if(p[i]<k)
            {
                ll kk=(1ll<<p[i])-1;
               // cout<<p[i]<<' '<<kk<<endl;
                if(!miller_rabin(kk))
                {
                    //cout<<kk<<' ';
                    num=0;
                    findx(kk);
                    sort(yz,yz+num);
                    int ss=0;
                    printf("%lld",yz[0]);
                    for(int j=1;j<num;j++)
                    {

                        printf(" * %lld",yz[j]);
                    }
                    printf(" = %lld = ( 2 ^ %d ) - 1\n",kk,p[i]);
                }
            }
        }
   }
   return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值