POJ 3159 Candies (差分约束)


Candies
Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 27843 Accepted: 7674

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get overc candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

题意:按顺序给出 A,B,c 表示孩子 B 最多可以比孩子 A 多得到 c 个糖果,

            孩子编号在 1--N 之间,问孩子 1 号和孩子 N 号最大相差多少糖果。

分析:由 b  - a <= c 。由a到b建立有向边,权值为c,由 1 到 n 跑一次最

            短路,得出最大的差值。

注意用 spfa 实现时不能用 queue,会超时,需用 stack。

代码如下:

法一(spfa):

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
#define N (30020) 
#define inf 0x3f3f3f3f 
int k, vis[N], dis[N], head[N], stack[N];
struct r
{
	int u, v, w, next;
}p[N*5];//开大点!
void add(int u, int v, int w)
{
	p[k].v=v;
	p[k].w=w;
	p[k].next=head[u];
	head[u]=k++;
}
void spfa()
{
	memset(vis, 0, sizeof(vis));
	memset(dis, inf, sizeof(dis));
	int top=0;
	stack[++top]=1;//用栈而不用队列(超时)
	vis[1]=1;
	dis[1]=0;
	while(top){
		int a=stack[top--];
		vis[a]=0;
		for(int i=head[a];i+1;i=p[i].next){
			if(dis[p[i].v]>dis[a]+p[i].w){//求最短路
				dis[p[i].v]=dis[a]+p[i].w;
				if(!vis[p[i].v]){
					stack[++top]=p[i].v;
					vis[p[i].v]=1;
				}
			}
		}
	}
}
int main()
{
#ifdef	OFFLINE
	freopen("t.txt","r",stdin);
#endif
	int i, j, n, m, a, b, c;
	while(~scanf("%d%d", &n, &m)){
		k=0;
		memset(head, -1, sizeof(head));
		while(m--){
			scanf("%d%d%d",&a, &b, &c);
			add(a, b, c);//b-a<=c
		}
		spfa();
		printf("%d\n", dis[n]);
	}
	return 0;
}

法二(dijkstra + heap ( priority_queue )):

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
#define N (30020) 
#define inf 0x3f3f3f3f 
int k, vis[N], mindis[N], head[N], stack[N];
struct r
{
	int cur, dis, next;
}edge[N*5];
struct node
{
	int cur, dis;
	node(int _cur, int _dis):cur(_cur),dis(_dis){}
	bool operator < (const node& no) const
	{
		return dis > no.dis;
	}
};
void add(int pre, int cur, int dis)
{
	edge[k].cur=cur;
	edge[k].dis=dis;
	edge[k].next=head[pre];
	head[pre]=k++;
}
void dijkstra(int s, int d)//+heap(priority_queue)
{
	int pre, e, cur;
	memset(mindis,inf,sizeof(mindis));
	memset(vis,0,sizeof(vis));
	priority_queue<node > q;//按大->小出队
	q.push(node(s, 0));
	vis[s]=1;
	mindis[s]=0;
	pre=s;
	for(int i=2;i<=d;i++){
		for(e=head[pre];e+1;e=edge[e].next){
			cur = edge[e].cur;
			if(!vis[cur] && mindis[pre]+edge[e].dis<mindis[cur])
			{
				mindis[cur]=mindis[pre]+edge[e].dis;
				q.push(node(cur, mindis[cur]));
			}
		}
		while(!q.empty()&&vis[q.top().cur]) q.pop();
		pre=q.top().cur;
		vis[pre]=1;
		q.pop();
	}
}
int main()
{
#ifdef	OFFLINE
	freopen("t.txt","r",stdin);
#endif
	int i, j, n, m, a, b, c;
	while(~scanf("%d%d", &n, &m)){
		k=0;
		memset(head, -1, sizeof(head));
		while(m--){
			scanf("%d%d%d",&a, &b, &c);
			add(a, b, c);//b-a<=c
		}
		dijkstra(1, n);
		printf("%d\n", mindis[n]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值