poj 3278 bfs入门+结构体进队列

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

 

题意:

已知农夫和牛的位置。农夫每次可以向前走一步或他所在位置的同等距离,向后走一步。问农夫最少移动几次可找到牛。

分析:

这题的神操作:结构体入队列

struct step{
        int x;
        int steps;
        step(int xx,int s):x(xx),steps(s) {}
};
queue<step> q;

具体应用见代码

#include <iostream>
#include<cstring>
#include<cstdio>
#include<queue>
using namespace std;
int n,m;
const int maxn=100000;
int visit[maxn+5];
struct step{
        int x;
        int steps;
        step(int xx,int s):x(xx),steps(s) {}
};
queue<step> q;
int main()
{
        scanf("%d %d",&n,&m);
        memset(visit,0,sizeof(visit));
        visit[n]=1;q.push(step(n,0));
        while(!q.empty())
        {
                step s=q.front();q.pop();
                if(s.x==m)
                {
                       cout<<s.steps<<endl;return 0;
                }
                else {
                        if(s.x-1>=0&&!visit[s.x-1])
                {
                        q.push(step(s.x-1,s.steps+1));
                        visit[s.x-1]=1;
                }
                 if(s.x+1<=maxn&&!visit[s.x+1])
                {
                        q.push(step(s.x+1,s.steps+1));
                        visit[s.x+1]=1;
                }
                if(s.x*2<=maxn&&!visit[s.x*2])
                {
                        q.push(step(s.x*2,s.steps+1));
                        visit[s.x-1]=1;
                }
                }
        }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值