Area
Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area.
You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself.
Input
The first line contains the number of scenarios.
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs dx,dy of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units.
Output
The output for every scenario begins with a line containing Scenario #i: where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.
Sample Input
2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3
Sample Output
Scenario #1:
0 4 1.0
Scenario #2:
12 16 19.0
题目大意
在方格坐标系中给定一系列点,这些点可以围城一块区域,要求依次求出该区域内的点数(不包含边界),区域边界上的点数以及区域的面积
分析
- 求区域边界点数:以整点为定点的线段覆盖的点数为
gcd(dx,dy)
(最大公因数),其中 dx , dy 分别代表该条线段在 x 轴方向和 y 轴方向占的点数。 - Pick(皮克)公式:用来求解整点坐标的多边形面积:S=a(多边形内部点数)+b(多边形外部点数)/2-1,在这道题中通过本公式可得
a=(S-(b/2)+1)
。 - 求解多边形面积:区域面积=按照一定顺序(顺时针或者逆时针)求相邻两点与原点组成的向量的叉积之和/2。
(把多边形分成多个三角形,每个点与原点构成向量,每两个向量叉积(模)/2为三角形面积)。
代码实现
/*皮克定理*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<vector>
using namespace std;
const int maxn = 110;
struct node {//记录坐标
int x, y;
}point[maxn];
int gcd(int a, int b) {//最大公因数(递归实现)
return b == 0 ? a : gcd(b, a % b);
}
double getArea(node a, node b) {//叉积得三角形面积
return a.x * b.y - a.y * b.x;
}
int main() {
int T, n;
double area;
int total, dx, dy;
scanf("%d", &T);
for (int num = 1;num <= T;num++) {
scanf("%d", &n);
area = 0;total = 0;
point[0].x = 0;point[0].y = 0;//原点
for (int i = 1;i <= n;i++) {
scanf("%d%d", &point[i].x, &point[i].y);
dx = abs(point[i].x);
dy = abs(point[i].y);
total += gcd(dx, dy);//边界点
point[i].x += point[i - 1].x;
point[i].y += point[i - 1].y;
area += getArea(point[i], point[i - 1]);
}
if (area < 0) {
area *= (-1);
cout << "Scenario #" << num << ':' << endl;
printf("%d %d %.1lf\n\n", (int)(area / 2 - total / 2 + 1), total, area / 2);
}
}
return 0;
}