Fishnet

Fishnet

A fisherman named Etadokah awoke in a very small island. He could see calm, beautiful and blue sea around the island. The previous night he had encountered a terrible storm and had reached this uninhabited island. Some wrecks of his ship were spread around him. He found a square wood-frame and a long thread among the wrecks. He had to survive in this island until someone came and saved him.

In order to catch fish, he began to make a kind of fishnet by cutting the long thread into short threads and fixing them at pegs on the square wood-frame. He wanted to know the sizes of the meshes of the fishnet to see whether he could catch small fish as well as large ones.

The wood frame is perfectly square with four thin edges on meter long: a bottom edge, a top edge, a left edge, and a right edge. There are n pegs on each edge, and thus there are 4n pegs in total. The positions of pegs are represented by their (x,y)-coordinates. Those of an example case with n=2 are depicted in figures below. The position of the ith peg on the bottom edge is represented by (ai,0). That on the top edge, on the left edge and on the right edge are represented by (bi,1), (0,ci) and (1,di), respectively. The long thread is cut into 2n threads with appropriate lengths. The threads are strained between (ai,0) and (bi,1),and between (0,ci) and (1,di) (i=1,…,n).

You should write a program that reports the size of the largest mesh among the (n+1)2 meshes of the fishnet made by fixing the threads at the pegs. You may assume that the thread he found is long enough to make the fishnet and the wood-frame is thin enough for neglecting its thickness.
在这里插入图片描述

Input

The input consists of multiple sub-problems followed by a line containing a zero that indicates the end of input. Each sub-problem is given in the following format.
n
a1 a2 … an
b1 b2 … bn
c1 c2 … cn
d1 d2 … dn
you may assume 0 < n <= 30, 0 < ai,bi,ci,di < 1

Output

For each sub-problem, the size of the largest mesh should be printed followed by a new line. Each value should be represented by 6 digits after the decimal point, and it may not have an error greater than 0.000001.

Sample Input

2
0.2000000 0.6000000
0.3000000 0.8000000
0.1000000 0.5000000
0.5000000 0.6000000
2
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
4
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
2
0.5138701 0.9476283
0.1717362 0.1757412
0.3086521 0.7022313
0.2264312 0.5345343
1
0.4000000
0.6000000
0.3000000
0.5000000
0

Sample Output

0.215657
0.111112
0.078923
0.279223
0.348958

题目大意

(请见下图理解),输入 n 大小的 a b c d 数组,并且按照图示进行网格构建,我们要求出所有网格面积的最大者
在这里插入图片描述

分析

思路比较清晰,主要是如何实现的问题,给出四个点(每两点代表一条直线)可以推导直线的交点公式,遍历每条边的两端点可以算对应的三角形的面积(与原点组成的向量叉积模的一半),进而得知每一块区域的面积,找最大值即可

代码

/* 相交:几何问题 */
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<vector>
using namespace std;
const int maxn = 1000100;
const int INF = (1 << 28);/*位运算*/
const double eps = 0.00000000001;//误差范围
int n;
struct Point {
	double x, y;
	//运算符的重载,注意以后的运算符使用重载含义
	friend double operator*(Point A, Point B) {
		return A.x * B.y - A.y * B.x;//叉积,求三角形面积用
	}
	friend Point operator-(Point A, Point B) {
		return { A.x - B.x,A.y - B.y };
	}
	friend Point operator+(Point A, Point B) {
		return { A.x + B.x,A.y + B.y };
	}
};
Point A[maxn], B[maxn], C[maxn], D[maxn];
Point inter_point(Point A, Point B, Point C, Point D) {
	double a = fabs((B - A) * (C - A));//乘以 0.5 放在最后统一处理了
	double b = fabs((B - A) * (D - A));
	double x = (a * D.x + b * C.x) / (a + b);//推导的交点公式
	double y = (a * D.y + b * C.y) / (a + b);
	return { x,y };
}
void solve() {
	double ans = 0;//初始化
	A[0] = { 0,0 };
	C[0] = A[0];
	B[0] = { 0,1 };
	C[n + 1] = B[0];
	D[0] = { 1,0 };
	A[n + 1] = D[0];
	B[n + 1] = { 1,1 };
	D[n + 1] = B[n + 1];
	for (int i = 0;i <= n;i++) {
		for (int j = 0;j <= n;j++) {
			Point a = inter_point(A[i], B[i], C[j], D[j]);
			Point b = inter_point(A[i + 1], B[i + 1], C[j], D[j]);
			Point c = inter_point(A[i], B[i], C[j + 1], D[j + 1]);
			Point d = inter_point(A[i + 1], B[i + 1], C[j + 1], D[j + 1]);
			double area = (b - a) * (d - a) * 0.5 + (d - a) * (c - a) * 0.5;
			if (area > ans + eps) ans = area;
		}
	}
	printf("%.6f\n", ans);
}
int main() {
	while (cin >> n && n) {
		for (int i = 1;i <= n;i++) {
			scanf("%lf", &A[i].x);
			A[i].y = 0;
		}
		for (int i = 1;i <= n;i++) {
			scanf("%lf", &B[i].x);
			B[i].y = 1;
		}
		for (int i = 1;i <= n;i++) {
			scanf("%lf", &C[i].y);
			C[i].x = 0;
		}
		for (int i = 1;i <= n;i++) {
			scanf("%lf", &D[i].y);
			D[i].x = 1;
		}
		solve();
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值