pat1011

19 篇文章 0 订阅

1011. World Cup Betting (20)

时间限制   400 ms   内存限制           32000 kB          代码长度限制         16000 B          判题程序     Standard     作者     CHEN, Yue


With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.


For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).


Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.


Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.


Sample Input
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
Sample Output
T T W 37.98

题目大意:对应输入的一个 3*3 的 double 数组,每行中选取数值最大的进行加和带入到题目中给出的公式中进行计算,

然后,去出最大数字的同时,记录最大数字在数组中的位序列。


这道题不难,比较复杂的题目形式是,在N*N 的数组中,不同行不同列的选出 N 个数字,使得总共的N个数字的和 最大/最小。


#include <cstdio>
#include <cstdlib>

double map[3][5] ;
int list[3] ;
char c[] = {'W','T','L'} ;

void inPut()
{
	for ( int i = 0 ; i < 3 ; i++ )
	{
		double max = -100 ;
		int loc = 0 ;

		for (int j = 0 ; j < 3 ; j++ )
		{
			scanf("%lf",&map[i][j]) ;
			if ( map [i][j] > max )
			{
				max = map[i][j] ;
				loc =  j ;
			}
		}

		map[i][3] = max ;
		list[i] = loc ;
	}
}

double calculate()
{
	double res = 0.65* 1.0;

	for (int i = 0 ; i < 3 ; i++ )
	{
		res *= map[i][3];
	}

	return (res-1)*2 ;
}

int main ( void )
{
	inPut() ;
	
	for ( int i = 0 ; i < 3 ; i++ )
	{
		printf("%c ",c[list[i]]) ;
	}

	printf("%.2lf",calculate()) ;

//	system("pause") ;

	return 0 ;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值