[kuangbin]专题五 并查集 The Suspects POJ - 1611【并查集】

【题目描述】
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
严重急性呼吸系统综合症(SARS)是一种病因不明的非典型肺炎,于2003年3月中旬被认为是一种全球性威胁。为了尽量减少对其他人的传播,最好的策略是将嫌疑人与其他嫌疑人分开。
在Not-Spreading-Your-Sickness University(NSYSU),有许多学生团体。 同一组中的学生经常互相交流,学生可以加入几个小组。 为了防止可能的SARS传播,NSYSU收集所有学生组的成员列表,并在其标准操作程序(SOP)中制定以下规则。
一旦组中的成员是嫌疑人,该组中的所有成员都是嫌疑人。
然而,他们发现,当学生被认定为嫌疑人时,识别所有嫌疑人并不容易。 你的工作是写一个找到所有嫌疑人的程序。

【输入】
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
输入文件包含几种情况。 每个测试用例以一行中的两个整数n和m开始,其中n是学生数,m是组的数量。 您可以假设0 <n <= 30000且0 <= m <= 500.每个学生都使用0到n-1之间的唯一整数进行编号,并且最初学生0在所有情况下都被识别为嫌疑人。 该行后面是组的m个成员列表,每组一行。 每行以整数k开头,表示组中的成员数。 在成员数量之后,有k个整数代表该组中的学生。 一行中的所有整数由至少一个空格分隔。
n = 0且m = 0的情况表示输入结束,无需处理。

【输出】
For each case, output the number of suspects in one line.
在每一个样例中,输出一行嫌疑犯的数量。

【样例输入】
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

【样例输出】
4
1
1

题目链接:https://vjudge.net/problem/POJ-1611

代码如下:

#include <iostream>
using namespace std;
static const int MAXN=30000;
int fa[MAXN+10];
int get(int x)
{
    if(x==fa[x])
        return x;
    return fa[x]=get(fa[x]);
}
void merge(int x,int y)
{
    fa[get(x)]=get(y);
}
int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0),cout.tie(0);
    int n,m;
    while(cin>>n>>m && !(n==0 && m==0))
    {
        for(int i=0;i<n;i++)
            fa[i]=i;
        for(int i=1;i<=m;i++)
        {
            int x,first;
            cin>>x>>first;
            for(int j=2;j<=x;j++)
            {
                int tmp;
                cin>>tmp;
                merge(tmp,first);
            }
        }
        int ans=1;
        for(int i=1;i<n;i++)
            if(get(i)==get(0))
                ans++;
        cout<<ans<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值