POJ - 1845 Sumdiv【快速幂】【分治】

【题目描述】
Consider two natural numbers A and B. Let S be the sum of all natural divisors of A^B. Determine S modulo 9901 (the rest of the division of S by 9901).

【输入】
The only line contains the two natural numbers A and B, (0 <= A,B <= 50000000)separated by blanks.

【输出】
The only line of the output will contain S modulo 9901.

【样例输入】
2 3

【样例输出】
15

【样例说明】
2^3 = 8.
The natural divisors of 8 are: 1,2,4,8. Their sum is 15.
15 modulo 9901 is 15 (that should be output).

题目链接:https://vjudge.net/problem/POJ-1845

代码如下:

#include <iostream>
using namespace std;
typedef long long ll;
static const int M=9901;
int power(int a,int b)
{
    int ans=1%M;
    for(;b;b>>=1)
    {
        if(b&1) ans=(ll)ans*a%M;
        a=(ll)a*a%M;
    }
    return ans;
}
int sum(int p,int c)
{
    if(c==0) return 1;
    else if(c&1) return (1+power(p,(c+1)>>1))*sum(p,(c-1)>>1)%M;
    else return ((1+power(p,c>>1))*sum(p,(c>>1)-1)+power(p,c))%M;
}
int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0),cout.tie(0);
    int a,b;
    cin>>a>>b;
    int ans=1;
    for(int i=2;i<=a;i++)
    {
        int c=0;
        while(a%i==0)
        {
            a/=i;
            c++;
        }
        ans=ans*sum(i,b*c)%M;
    }
    cout<<ans<<endl;
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值