POJ - 3784 Running Median【STL】

【题目描述】
For this problem, you will write a program that reads in a sequence of 32-bit signed integers. After each odd-indexed value is read, output the median (middle value) of the elements received so far.

【输入】
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by an odd decimal integer M, (1 ≤ M ≤ 9999), giving the total number of signed integers to be processed. The remaining line(s) in the dataset consists of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.

【输出】
For each data set the first line of output contains the data set number, a single space and the number of medians output (which should be one-half the number of input values plus one). The output medians will be on the following lines, 10 per line separated by a single space. The last line may have less than 10 elements, but at least 1 element. There should be no blank lines in the output.

【样例输入】
3
1 9
1 2 3 4 5 6 7 8 9
2 9
9 8 7 6 5 4 3 2 1
3 23
23 41 13 22 -3 24 -31 -11 -8 -7
3 5 103 211 -311 -45 -67 -73 -81 -99
-33 24 56

【样例输出】
1 5
1 2 3 4 5
2 5
9 8 7 6 5
3 12
23 23 22 22 13 3 5 5 3 -3
-7 -3

题目链接:https://vjudge.net/problem/POJ-3784

代码如下:

#include <iostream>
#include <queue>
using namespace std;
priority_queue<int> Q2;
priority_queue<int,vector<int>,greater<int> > Q1;
int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0),cout.tie(0);
    int T;
    cin>>T;
    while(T--)
    {
        while(Q1.size())
            Q1.pop();
        while(Q2.size())
            Q2.pop();
        int kase,n,x;
        cin>>kase>>n;
        cout<<kase<<" "<<n/2+1<<endl;
        int cnt=0;
        for(int i=1;i<=n;i++)
        {
            cin>>x;
            if(Q1.empty() || x>Q1.top())
                Q1.push(x);
            else
                Q2.push(x);
            while(Q1.size()-1>Q2.size())
            {
                int temp=Q1.top();
                Q1.pop();
                Q2.push(temp);
            }
            while(Q2.size()>Q1.size())
            {
                int temp=Q2.top();
                Q2.pop();
                Q1.push(temp);
            }
            if(i&1)
            {
                cnt++;
                cout<<Q1.top();
                if(i==n || cnt%10==0)
                    cout<<endl;
                else
                    cout<<" ";                
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值