2001-Singapore problem 1 Encryption

Problem 1

Encryption

Input file: data1.txt

Say you are the founder and sole employee of your own e-business start-up. Hours before delivering an e-commerce solution to your very first client, you realize to your horror that you have forgotten to include encryption features for sensitive information.

Faced with a very tight deadline, you decide to incorporate a simple encryption routine and later sell a security upgrade to your client at a tidy sum. After looking through possible methods that you can implement quickly, you finally settle on the following scheme known as a Vigenere cipher.

First, you determine a small repeated key that is the length of your plaintext (unencrypted) message. Next, you align the plaintext message such that the first letter of the message is aligned to the first letter of the key. Finally, each key letter index is added to its corresponding plaintext letter index to produce the ciphertext (encrypted) letter index. These combined ciphertext letter indices will form the final encrypted message. Your task is to write such a program.

Input

The input file consists of pairs of lines. The first line of each pair will contain the key while the second line will contain the plaintext message. Only letters of the alphabet (A-Z) plus a space will be used. These may be in upper- or lower-case and you will have to convert them into upper-case if necessary.

Output

The output file consists of one line of upper-case text for each pair of lines in the input file. Each line will contain the encrypted message.

Sample Input

ABCABCABCABCAB

Attack at dawn

shineshines

How are you

Sample Output

BVWBENACWAFDXP

AWFNFKMIMTN





//Author IPLinger
//IDE VC++6.0

pragma hdrstop
# include <fstream>
# include <string>
# include <iostream>
using namespace std;

char key[1000];
char message[1000];
char result[1000];
string key_string; //the purpose is to caculate the length of key-array.

//Encrypt
void Encrypt()
{
 key_string=key;
 int temp1;
 int temp2;
 char temp3;
 for(int i=0;i< key_string.length();i++)
 {
  temp1= key[i]-64;
  temp2= message[i];
                temp2-= temp2==32 ? 32 : 64;
  temp3= temp1+temp2;
                temp3+= temp3>26 ? 64-26 : 64;
  cout << temp3;
 }
}

//读取文件
void ReadFile()
{
 ifstream OpenFile("/mnt/hgfs/ACM/solution/2001-singapore/data1.txt");
        //打开文件,you should apply the path and name of the file that you want to open in linux;
 while(!OpenFile.eof())
        //eof()函数用来判断文件的结束,规定 # 为input的结束
 {
  OpenFile.getline(key,1000);
  OpenFile.getline(message,1000);
                strupr(key);
                strupr(message);
                //method strupr() converts a string to uppercase.
  Encrypt();
  cout<< endl;
 }
 OpenFile.close();
        //关闭文件资源
}

void main()
{
 ReadFile();
        //char a;
        //cin>> a;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值