PAT-A1149 Dangerous Goods Packaging/PAT-B1090 危险品装箱 (25)

甲级题目: 

When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化剂) must not be packed with flammable liquid (易燃液体), or it can cause explosion.

Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: N (≤10​4​​), the number of pairs of incompatible goods, and M (≤100), the number of lists of goods to be shipped.

Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:

K G[1] G[2] ... G[K]

where K (≤1,000) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.

Output Specification:

For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.

Sample Input:

6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333

Sample Output:

No
Yes
Yes

乙级题目:

集装箱运输货物时,我们必须特别小心,不能把不相容的货物装在一只箱子里。比如氧化剂绝对不能跟易燃液体同箱,否则很容易造成爆炸。

本题给定一张不相容物品的清单,需要你检查每一张集装箱货品清单,判断它们是否能装在同一只箱子里。

输入格式:

输入第一行给出两个正整数:N (≤10​4​​) 是成对的不相容物品的对数;M (≤100) 是集装箱货品清单的单数。

随后数据分两大块给出。第一块有 N 行,每行给出一对不相容的物品。第二块有 M 行,每行给出一箱货物的清单,格式如下:

K G[1] G[2] ... G[K]

其中 K (≤1000) 是物品件数,G[i] 是物品的编号。简单起见,每件物品用一个 5 位数的编号代表。两个数字之间用空格分隔。

输出格式:

对每箱货物清单,判断是否可以安全运输。如果没有不相容物品,则在一行中输出 Yes,否则输出 No

输入样例:

6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333

输出样例:

No
Yes
Yes

 把不兼容关系存为图(邻接表),然后暴力法枚举

#include <cstdio>
#include <map>
#include <vector>
#include <algorithm>
using namespace std;
const int MAXN=1e5+10;

int N,M,K,cnt=0;
map<int,int> mp;
vector<int> adj[MAXN],conta;
int getid(int id){
    if(mp[id]==0) mp[id]=++cnt;
    return mp[id];
}
bool isConnected(int v){
    for(int i=0;i<conta.size();++i){
        int u=conta[i];
        for(int j=0;j<adj[u].size();++j)
            if(adj[u][j]==v)
                return true;
    }
    return false;
}
int main()
{
    int u,v,a,b;
    scanf("%d%d",&N,&M);
    for(int i=0;i<N;++i){
        scanf("%d%d",&a,&b);
        u=getid(a);v=getid(b);
        adj[u].push_back(v);
        adj[v].push_back(u);
    }
    bool flag;
    for(int i=0;i<M;++i){
        conta.clear();
        flag=true;
        scanf("%d%d",&K,&a);
        u=getid(a);
        conta.push_back(u);
        for(int j=1;j<K;++j){
            scanf("%d",&b);
            if(!flag) continue;
            v=getid(b);
            if(isConnected(v)){
                flag=false;
                printf("No\n");
            }else
                conta.push_back(v);
            u=v;
        }
        if(flag) printf("Yes\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值