POJ 2907 Collecting Beepers DFS+回溯+剪枝

http://poj.org/problem?id=2907

Collecting Beepers
Time Limit:1000MS Memory Limit:65536K

Description

Karel is a robot who lives in a rectangular coordinate system where each place is designated by a set of integer coordinates (xandy). Your job is to design a program that will help Karel pick up a number of beepers that are placed in her world. To do so you must direct Karel to the position where each beeper is located. Your job is to write a computer program that finds the length of the shortest path that will get Karel from her starting position, to each of the beepers, and return back again to the starting position.

Karel can only move along the x and y axis, never diagonally. Moving from one position (i,j) to an adjacent position (i,j+ 1), (i,j− 1), (i− 1,j), or (i+ 1,j) has a cost of one.

You can assume that Karel’s world is never larger than 20 × 20 squares and that there will never be more than 10 beepers to pick up. Each coordinate will be given as a pair (x,y) where each value will be in the range 1 through the size of that particular direction of the coordinate system.

Input

First there will be a line containing the number of scenarios you are asked to help Karel in. For each scenario there will first be a line containing the size of the world. This will be given as two integers (x-size andy-size). Next there will be one line containing two numbers giving the starting position of Karel. On the next line there will be one number giving the number of beepers. For each beeper there will be a line containing two numbers giving the coordinates of each beeper.

Output

The output will be one line per scenario, giving the minimum distance that Karel has to move to get from her starting position to each of the beepers and back again to the starting position.

Sample Input

1
10 10
1 1
4
2 3
5 5
9 4
6 5

Sample Output

The shortest path has length 24
/* Author : yan
 * Question : POJ 2907 Collecting Beepers
 * Date && Time : Sunday, December 26 2010  10:14 PM
 * Compiler : gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
*/
#include<stdio.h>
#define bool _Bool
#define false 0
#define true 1
bool visited[21];
int mapx[21],mapy[21];
int x_size,y_size;
int start_x,start_y;

int beepers;

int ans;///答案

int cnt;///当前捡起的beeper数目
int path;///当前的路径长度

void DFS(int a,int b)
{
	int cache;///临时变量
	if(cnt==beepers)
	{
		cache=path+abs(a-start_x)+abs(b-start_y);///往返路程,由于当全部捡起时回到原点的最短路径就是abs(a-start_x)+abs(b-start_y)
		if(ans>cache) ans=cache;
		return;
	}
	int i;
	for(i=0;i<beepers;i++)
	{
		if( visited[i] ) continue;///剪枝
		visited[i]=true;
		cache=abs(mapx[i]-a)+abs(mapy[i]-b);
		cnt++;
		path+=cache;
		DFS(mapx[i],mapy[i]);
		path-=cache;///回溯
		cnt--;
		visited[i]=false;
	}
}
int main()
{
	freopen("input","r",stdin);
	int test;

	int i;

	int x,y;
	scanf("%d",&test);
	while(test--)
	{
		memset(visited,false,sizeof(visited));
		path=0;
		cnt=0;
		ans=999999;
		scanf("%d %d",&x_size,&y_size);
		scanf("%d %d",&start_x,&start_y);
		scanf("%d",&beepers);
		for(i=0;i<beepers;i++)
		{
			scanf("%d %d",&mapx[i],&mapy[i]);
		}
		DFS(start_x,start_y);
		printf("The shortest path has length %d/n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值