POJ 1423 Big Number 大数阶乘的位数计算

Big Number
Time Limit:1000MSMemory Limit:65536K
Total Submissions:17518Accepted:5541

Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= m <= 10^7 on each line.

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2
10
20

Sample Output

7
19
我们知道整数n的位数的计算方法为:log10(n)+1
故n!的位数为log10(n!)+1
由于这是高精度没法用普通方式计算阶乘,否则会TLE
可以用斯特林(Stirling)公式求解
 
斯特林( Stirling )公式:

于是求n!的位数就是求log10((2*PI*n)^1/2*(n/e)^n)+1
即  1/2*log10(2*PI*n)+n*log10(n/e)+1
/* Author yan
*/
#include<stdio.h>
#define PI 3.141592654
#define E 2.71828182846
int l(int n)
{
	int s=1;
	if(n>3)
		s=log10(2*PI*n)/2+n*log10(n/E)+1;
	return s;
}
int main()
{
	int n;
	int _i,cache;
	scanf("%d",&n);
	for(_i=0;_i<n;_i++)
	{
		scanf("%d",&cache);
		printf("%d/n",l(cache));
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值