POJ 2536 最大匹配入门

Gopher II
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 3680 Accepted: 1539

Description

The gopher family, having averted the canine threat, must face a new predator.

The are n gophers and m gopher holes, each at distinct (x, y) coordinates. A hawk arrives and if a gopher does not reach a hole in s seconds it is vulnerable to being eaten. A hole can save at most one gopher. All the gophers run at the same velocity v. The gopher family needs an escape strategy that minimizes the number of vulnerable gophers.

Input

The input contains several cases. The first line of each case contains four positive integers less than 100: n, m, s, and v. The next n lines give the coordinates of the gophers; the following m lines give the coordinates of the gopher holes. All distances are in metres; all times are in seconds; all velocities are in metres per second.

Output

Output consists of a single line for each case, giving the number of vulnerable gophers.

Sample Input

2 2 5 10
1.0 1.0
2.0 2.0
100.0 100.0
20.0 20.0

Sample Output

1

Source

敲错了一个变量,让我WA了很久都没看出来。。

Source Code

Problem: 2536 User: bingshen
Memory: 748K Time: 32MS
Language: G++ Result: Accepted
  • Source Code
    #include<stdio.h>
    #include<algorithm>
    #include<string.h>
    #include<math.h>
    #include<vector>
    
    using namespace std;
    
    struct Point
    {
    	double x;
    	double y;
    };
    
    Point p1[105];
    Point p2[105];
    vector<int>map[105];
    int link[105];
    bool cover[105];
    int n,m;
    
    void init()
    {
    	memset(link,-1,sizeof(link));
    	memset(map,0,sizeof(map));
    }
    
    double dis(Point a,Point b)
    {
    	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
    }
    
    void makemap(int s,int v)
    {
    	int i,j;
    	double r;
    	r=s*v;
    	for(i=0;i<n;i++)
    		for(j=0;j<m;j++)
    		{
    			if(dis(p1[i],p2[j])<=r)
    				map[i].push_back(j);
    		}
    }
    
    bool find(int v)
    {
    	int i;
    	for(i=0;i<map[v].size();i++)
    	{
    		if(!cover[map[v][i]])
    		{
    			cover[map[v][i]]=true;
    			if(link[map[v][i]]==-1||find(link[map[v][i]]))
    			{
    				link[map[v][i]]=v;
    				return true;
    			}
    		}
    	}
    	return false;
    }
    
    int main()
    {
    	int i,life;
    	double s,v;
    	while(scanf("%d%d%lf%lf",&n,&m,&s,&v)!=EOF)
    	{
    		init();
    		life=0;
    		for(i=0;i<n;i++)
    			scanf("%lf%lf",&p1[i].x,&p1[i].y);
    		for(i=0;i<m;i++)
    			scanf("%lf%lf",&p2[i].x,&p2[i].y);
    		makemap(s,v);
    		for(i=0;i<n;i++)
    		{
    			memset(cover,0,sizeof(cover));
    			if(find(i))
    				life++;
    		}
    		printf("%d/n",n-life);
    	}
    	return 0;
    }
    
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值