JDK里面这样子写代码是否有深意啊?

public V get(Object key) {
Iterator<Entry<K,V>> i = entrySet().iterator();
if (key==null) {
while (i.hasNext()) {
Entry<K,V> e = i.next();
if (e.getKey()==null)
return e.getValue();
}
} else {
while (i.hasNext()) {
Entry<K,V> e = i.next();
if (key.equals(e.getKey()))
return e.getValue();
}
}
return null;
}
今天无意中在查看java.util.AbstractMap<K,V>这个类时看到上面这段代码,我的问题就是为什么不把key==null的判断写到while循环里面写成:
public V get(Object key) {
Iterator<Entry<K,V>> i = entrySet().iterator();
while (i.hasNext()) {
Entry<K,V> e = i.next();
if (key==null) {
if (e.getKey()==null) return e.getValue();
} else{
if (key.equals(e.getKey())) return e.getValue();
}
}
return null;
}
或者写成:
public V get(Object key) {
Iterator<Entry<K,V>> i = entrySet().iterator();
while (i.hasNext()) {
Entry<K,V> e = i.next();
if (e.getKey()==key || key.equals(e.getKey()))
return e.getValue();
}
return null;
}
我一向比较崇拜JDK的代码,难道他们这样子写有什么深意,比如效率考虑???
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值