在pom.xml文件中指定编译的版本

今天上午用maven来编译java类时,一个类总是出现不支持泛型的错误提示。泛型是从JDK5.0+才开始支持的,而我在eclipse中所用的JRE版本都是5.0以上的。后来才发现必须在pom.xml文件中加入下一面一段语句来指定所用的版本,尽管在eclipse中配置了正确的“Build Path”:
<build>
<plugins>
<plugin>
<artifactId>maven-compiler-plugin</artifactId>
<configuration>
<target>1.5</target>
<source>1.5</source>
<encoding>UTF-8</encoding>
</configuration>
</plugin>
</plugins>
</build>
阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页