COJ - 1005 - Rent your Airplane and make Money 题解

Description

"ABEAS Corp." is a very small company that owns a single airplane. The customers of ABEAS Corp are large airline companies which rent the airplane to accommodate occasional overcapacity. Customers send renting orders that consist of a time interval and a price that the customer is ready to pay for renting the airplane during the given time period. Orders of all the customers are known in advance. Of course, not all orders can be accommodated and some orders have to be declined. Eugene LAWLER, the Chief Scientific Officer of ABEAS Corp would like to maximise the profit of the company. You are requested to compute an optimal solution.

Small Example: Consider the case where the company has 4 orders:
  • Order 1 (start time 0, duration 5, price 10).
  • Order 2 (start time 3, duration 7, price 8).
  • Order 3 (start time 5, duration 9, price 7).
  • Order 4 (start time 6, duration 9, price 8).
The optimal solution consists in declining Order 2 and 3 and the gain is 10 + 8 = 18. Note that the solution made of Order 1 and 3 is feasible (the airplane is rented with no interruption from time 0 to time 14) but non-optimal.

Input specification

The first line of the input contains a number T (1 <= T <= 30)that indicates the number of test cases to follow. The first line of each test case contains the number of orders n (0 <= n <= 10000). In the following nlines the orders are given. Each order is described by 3 integer values: The start time of the order st (0 <= st < 10^6), the duration dof the order (0 < d < 10^6), and the price p (0 < p < 10^5) the customer is ready to pay for this order.

Output specification

You are required to compute an optimal solution. For each test case your program has to write the total price paid by the airlines.

Sample input
1
4
0 5 10
3 7 14
5 9 7
6 9 8
Sample output
18

任务调度问题,不过这里变形了,需要考虑到选择这个任务的最大效益,那么就只能使用动态规划法了,不能使用贪心法了。所以时间效率是O(n^2)。

思想:

1 先按任务开始时间排序

2 然后从后往前使用动态规划法(这里不能从前往后了)

3 如果当前任务结束时间是小于等于后面某个任务,那么就是当前任务可以和后面任务并行执行

4 那么就比较两种情况填表:a 选择当前任务的效益 b 不选择当前任务的效益, 那个大就填那个

这样如下写程序:

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;

struct Task
{
	int st, dur, price;
	bool operator<(const Task &t) const
	{
		return st < t.st;
	}
	bool operator<(const int a) const
	{
		return st < a;
	}
};

//for ( ; j >= 0 && vt[j].st + vt[j].dur > vt[i].st; j--);逻辑错误
int tasksPicker(vector<Task> &vt)
{
	vector<int> prices(vt.size()+1);
	prices[vt.size()-1] = vt[vt.size()-1].price;
	for (int i = vt.size()-2; i >= 0 ; i--)
	{
		int j=lower_bound(vt.begin()+i+1,vt.end(),vt[i].st+vt[i].dur)-vt.begin();
		prices[i] = max(prices[i+1], vt[i].price+prices[j]);
	}
	return prices[0];
}

void RentyourAirplaneandmakeMoney()
{
	int T = 0, n = 0, cap;
	cin>>T;
	while (T--)
	{
		cin>>n;
		vector<Task> vt(n);
		cap = 0;
		for (int i = 0; i < n; i++)
		{
			cin>>vt[i].st>>vt[i].dur>>vt[i].price;
			cap = max(cap, vt[i].st + vt[i].dur);
		}
		sort(vt.begin(), vt.end());
		cout<<tasksPicker(vt)<<endl;
	}
}

int main()
{
	RentyourAirplaneandmakeMoney();
	return 0;
}




SDUT-OJ(Software Development University of Tsinghua Online Judge)是一个在线编程平台,提供给清华大学软件学院的学生和爱好者练习和解决算法问题的环境,其中包括各种计算机科学题目,包括数据结构、算法、图形等。对于"最小生成树"(Minimum Spanning Tree, MST)问题,它是图论中的经典问题,目标是从一个加权无向图中找到一棵包含所有顶点的树,使得树的所有边的权重之和最小。 在C语言中,最常见的是使用Prim算法或Kruskal算法来求解最小生成树。Prim算法从一个顶点开始,逐步添加与当前生成树相连且权重最小的边,直到所有顶点都被包含;而Kruskal算法则是从小到大对所有边排序,每次选取没有形成环的新边加入到树中。 如果你想了解如何用C语言实现这些算法,这里简单概括一下: - 通常使用优先队列(堆)来存储边和它们的权重,以便快速查找最小值。 - 从任意一个顶点开始,遍历与其相邻的边,若新边不形成环,就更新树,并将新边加入优先队列。 - Kruskal算法: - 先将所有的边按照权重升序排序。 - 创建一个空的最小生成树,然后依次取出排序后的边,如果这条边连接的两个顶点不在同一个连通分量,则将其添加到树中。 如果你需要更详细的代码示例,或者有具体的问题想了解(比如如何处理环、如何实现优先队列等),请告诉我,我会为你提供相应的帮助。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值