巧妙利用中国剩余定理(九度 1142)

本文介绍了一个基于中国剩余定理的问题解决方法,该问题是确定一个人生命中的三个周期(体力、情绪和智力)何时会同时达到峰值。通过编程实现,找到了一个最小的数X,满足特定的模运算条件,从而确定了下一个三周期峰值出现的时间。
摘要由CSDN通过智能技术生成
题目描述:

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier.
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.

输入:

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

输出:

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:

Case 1: the next triple peak occurs in 1234 days.

Use the plural form "days'' even if the answer is 1.

样例输入:
0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1
样例输出:
Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.


简单的来说,就是求一个最小的数X。使得 X % 23 = p; X % 28 = e; X % 33 = i;

这就是著名的中国剩余定理。


数学上的常规解法是这样的:

找到一个找到一个自然数t,使得 (e*i) * t % 23 = p .这里的t要从1开始试。 令 a =(e*i) * t

再依次找到 b,c。 a+b+c则符合条件。


编程中,有一个更简便的方法。

找到一个数使得X , 使得 X % (e * i) = 1; (可使用上面的方法一个一个试)。

则 X * p % (e * i) = p;

代码如下:

5544 % 23 = 1; 5544 % (28 * 33) = 0;

#include <stdio.h>
int main()
{
	int p, e, i, n, sum, t;
	t = 0;
	while (scanf("%d%d%d%d", &p, &e, &i, &n), p + e + i + n != -4)
	{
		sum = (5544 * p + 14421 * e + 1288 * i) % 21252;
		if (sum - n <= 0)
			sum += 21252;
		printf("Case %d: the next triple peak occurs in %d days.\n", ++t,
				sum - n);
	}
	return 0;
}






 
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值