九度 1044:Pre-Post 递归求n叉树结构个数

题目描述:

We are all familiar with pre-order, in-order and post-order traversals of binary trees. A common problem in data structure classes is to find the pre-order traversal of a binary tree when given the in-order and post-order traversals. Alternatively, you can find the post-order traversal when given the in-order and pre-order. However, in general you cannot determine the in-order traversal of a tree when given its pre-order and post-order traversals. Consider the four binary trees below:



All of these trees have the same pre-order and post-order traversals. This phenomenon is not restricted to binary trees, but holds for general m-ary trees as well.

输入:

Input will consist of multiple problem instances. Each instance will consist of a line of the form
m s1 s2
indicating that the trees are m-ary trees, s1 is the pre-order traversal and s2 is the post-order traversal.All traversal strings will consist of lowercase alphabetic characters. For all input instances, 1 <= m <= 20 and the length of s1 and s2 will be between 1 and 26 inclusive. If the length of s1 is k (which is the same as the length of s2, of course), the first k letters of the alphabet will be used in the strings. An input line of 0 will terminate the input.

输出:
For each problem instance, you should output one line containing the number of possible trees which would result in the pre-order and post-order traversals for the instance. All output values will be within the range of a 32-bit signed integer. For each problem instance, you are guaranteed that there is at least one tree with the given pre-order and post-order traversals.

样例输入:
2 abc cba
2 abc bca
10 abc bca
13 abejkcfghid jkebfghicda
样例输出:
4
1
45
207352860
来源:
2008年上海交通大学计算机研究生机试真题

题目大意:对于n叉树,给出先序遍历和后续遍历,求可能的个数。

例如:

10 abc bca
根节点为a是确定的,接下来是 bc bc
可知b,c在同一级别,有C(10,2)=45 (10个位置中取两个)

2 abc cba
同样根节点为a,然后是 bc cb

b,c在两层 C(2,1) * C(2,1)=4


对于这个就有些复杂了,

13 abejkcfghid jkebfghicda
第一步拆分为 三部分 (bejk, cfghi, d) * C(13,3)

再继续递归下去,直到字符串长度为1



#include <stdio.h>
#include <string>
#include <iostream>
using namespace std;
int c[21][21];
int n;
long long test(string pre, string post) {
	long long sum = 1;
	int num = 0;
	 int k = 0, i;
	pre.erase(pre.begin());
	post=post.substr(0, post.length()-1);
	while (k < pre.length()) {
		for (i = 0; i < post.length(); i++)
			if (pre[k] == post[i]) {
				sum *= test(pre.substr(k, i - k + 1),
						post.substr(k, i - k + 1));

				//num代表串被分成了几段(例如 (bejkcfghid,jkebfghicd) = (bejk, cfghi, d) , num=3)
				num++;
				k = i + 1;
				break;
			}
	}
	//cout << pre << "  " << post <<"  " << t1 << " =" << num << endl << endl;
	sum *= c[num][n]; //从n中取num个的取法个数
	return sum;
}

void getsc() {
	int i, j;
	c[0][1] = c[1][1] = 1;
	for (i = 2; i < 21; i++) {
		c[0][i] = 1;
		for (j = 1; j <= i; j++){
			if (i == j)
				c[j][i] = 1;
			else
				c[j][i] = c[j - 1][i - 1] + c[j][i - 1];
		}
	}
}

int main() {
	freopen("in.txt", "r", stdin);
	string pre, post;
	getsc();
	while ((cin >> n >> pre >> post) && n) {
		cout << test(pre, post) << endl;
	}
	return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值