1119 Pre- and Post-order Traversals (30分)-前序后序重构树,唯一性判定

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

解题思路:

  1. 树不唯一的原因:根据一棵树的前序和后序序列可以重构一颗树,但结果可能不唯一,原因是如果一个子树的根有单个子结点,无论子结点放在根的左子树还是右子树,该子树的前序和后序序列都是一样的,这就造成结构不同树可能对应同一前序、后序序列组合,这种多对一的对应关系造成由前序、后序序列还原树的时候结果可能不唯一;
  2. 树的还原:前序序列的第一个元素和后序序列的最后一个元素为树的根结点,前序序列的第二个元素x为树的子结点,在后序序列中查找x,如果x为后序序列的倒数第二个元素,说明后序序列的第一个元素至倒数第二个元素在同一个子树内,说明树只有一个非空的子树,它可以为左子树,也可以为右子树,树不唯一,这时可以将子树默认为右子树。当x为后序序列的第i(非倒数第二)个元素时,第1~i元素为树的左子树的后序序列,第i+1至倒数第二个元素为右子树的后序序列,可以进行下一步递归构建。

AC代码:

#include <iostream> 
#include <stack>
#include <malloc.h>
using namespace std;
#define Max 30
typedef struct node* tree;
struct node{
	int data;
	tree left;
	tree right;
};
int IsUnique=1,cnt=0; 
tree CreateTree(int* pre,int sp1,int tp1,int* post,int sp2,int tp2);
void intravel(tree t,int N);
int main(){
	int N,i,pre[Max],post[Max];
	cin>>N;
	for(i=0;i<N;i++)
		cin>>pre[i];
	for(i=0;i<N;i++)
		cin>>post[i];	
	tree t=CreateTree(pre,0,N-1,post,0,N-1);
	if(IsUnique)
		printf("Yes\n");
	else 
		printf("No\n");
	intravel(t,N);
	printf("\n");
	return 0;
}
void intravel(tree t,int N){
	if(t){
		intravel(t->left,N);
		printf("%d",t->data);
		cnt++;
		if(cnt!=N)
			printf(" ");
		intravel(t->right,N);		
	}	
}
tree CreateTree(int* pre,int sp1,int tp1,int* post,int sp2,int tp2){
	tree head=(tree)malloc(sizeof(struct node));
	head->data=pre[sp1];
	head->left=NULL;
	head->right=NULL;
	if(tp1>sp1){
		int i;
		for(i=sp2;i<=tp2-1;i++)
			if(post[i]==pre[sp1+1])
				break;
		if(i==tp2-1){
			IsUnique=0;
		//	head->left=CreateTree(pre,sp1+1,tp1,post,sp2,tp2-1);//把单子结点放在左边 
			head->right=CreateTree(pre,sp1+1,tp1,post,sp2,tp2-1);//把单子结点放在右边
		}
		else{
			head->left=CreateTree(pre,sp1+1,sp1+1+i-sp2,post,sp2,i);
			head->right=CreateTree(pre,sp1+2+i-sp2,tp1,post,i+1,tp2-1);		
		}	
	}
	return head;	
}
	
	
	
	

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值