UVA 10041 (13.08.25)

Problem C: Vito's family

Background

The world-known gangster Vito Deadstone is moving to New York. He hasa very big family there, all of them living in Lamafia Avenue. Sincehe will visit all his relatives very often, he is trying to find ahouse close to them.

Problem

Vito wants to minimize the total distance toall of them and has blackmailed you to write a program that solves his problem.

Input

The input consists of several test cases. The first line contains the number of test cases.

For each testcase you will be given the integer number of relatives r (0 < r < 500)and the street numbers (also integers) $s_1, s_2, \ldots, s_i, \ldots, s_r$wherethey live (0 < si < 30000 ). Note that several relatives could live inthe same street number.

Output

For each test case your program must write the minimal sum ofdistances from the optimal Vito's house to each one of hisrelatives. The distance between two street numbers s i and s j is d ij= | s i- s j|.

Sample Input

2
2 2 4 
3 2 4 6

Sample Output

2
4

题意:

给主人公找个安家的位置, 使得与所有邻居距离的和最小~


思路:

找中位数, 然后所有的距离减去中位数即可

水题~


AC代码:

#include<stdio.h>
#include<algorithm>

using namespace std;

int R[555];

int main() {
    int T;
    scanf("%d", &T);
    while(T--) {
        int r;
        scanf("%d", &r);
        for(int i = 0; i < r; i++)
            scanf("%d", &R[i]);
        sort(R, R+r);
        int mid = R[r/2];
        int sum = 0;
        for(int i = 0; i < r; i++) {
            if(R[i] > mid)
                sum += R[i] - mid;
            else 
                sum += mid - R[i];
        }
        printf("%d\n", sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值