UVa 10041 Vito's Family (中位数&快速选择)

10041 - Vito's Family

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=982

Background 

The world-known gangster Vito Deadstone is moving to New York. He has a very big family there, all of them living in Lamafia Avenue. Since he will visit all his relatives very often, he is trying to find a house close to them.

Problem 

Vito wants to minimize the total distance to all of them and has blackmailed you to write a program that solves his problem.

Input 

The input consists of several test cases. The first line contains the number of test cases.

For each test case you will be given the integer number of relatives r ( 0 < r < 500) and the street numbers (also integers) $s_1, s_2, \ldots, s_i, \ldots, s_r$ where they live ( 0 < si < 30000 ). Note that several relatives could live in the same street number.

Output 

For each test case your program must write the minimal sum of distances from the optimal Vito's house to each one of his relatives. The distance between two street numbers  s i  and  s j  is  d ij = | s i - s j |.

Sample Input 

2
2 2 4 
3 2 4 6

Sample Output 

2
4


排序求中位数即可。

优化:快速选择


排序代码:

复杂度:O(rlog r)

/*0.025s*/

#include<cstdio>
#include<algorithm>
using namespace std;

int s[505];

int main(void)
{
	int t, r, sum;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d", &r);
		for (int i = 0; i < r; ++i)
			scanf("%d", &s[i]);
		sort(s, s + r);
		sum = 0;
		for (int i = (r >> 1) + (r & 1); i < r; ++i)
			sum += s[i] - s[r - i - 1];
		printf("%d\n", sum);
	}
	return 0;
}

快速选择代码:

复杂度:O(r),但系数大

速度反而比上面慢是因为这题r太小,系数对运行时间的影响大。

/*0.032s*/

#include<cstdio>
#include<cstdlib>
#include<algorithm>
using namespace std;

int s[505];

int main(void)
{
	int t, r, sum, mid;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d", &r);
		for (int i = 0; i < r; ++i)
			scanf("%d", &s[i]);
		nth_element(s, s + (r >> 1), s + r);
		mid = s[r >> 1], sum = 0;
		for (int i = 0; i < r; ++i)
			sum += abs(mid - s[i]);
		printf("%d\n", sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值