A/B&&http://acm.hdu.edu.cn/showproblem.php?pid=1576

Problem Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。

Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。

Output
对应每组数据输出(A/B)%9973。

Sample Input
 
 
2 1000 53 87 123456789

Sample Output
 
 
7922 6060
思路:扩展欧几里得算法的应用
AC代码:
#include<iostream>
#include<string.h>
#include<string>
#include<cstdio>
#define N 9973
using namespace std;
void _gcd(int a,int b,int &x1,int &y1)
{
	if(!b) x1=1,y1=0;
	else
	{
		_gcd(b,a%b,x1,y1);
		int temp=x1;
		 x1=y1;
		 y1=temp-a/b*x1;
	}
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int a,c;
		scanf("%d%d",&c,&a);
		int b=9973;
		int x1,y1;
		_gcd(a,b,x1,y1);
		printf("%d\n",((x1%N)*(c%N)%N+N)%N);
	}return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值