http://acm.hdu.edu.cn/showproblem.php?pid=2612-(广搜)

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
Input The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
Output For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet. Sample Input
4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#
Sample Output
66
88
66

解析:这道题题意是Y和M同去一个@ ,@点有多个,然后计算两者到同一个点时间(算出距离后乘以11)和的最小值。

之前做的广搜都是搜索一条路,这道题是搜索两条路,因此我们可以用一个二维数组存下来,给这个数组赋初值为0x3f3f3f3f,然后找到里面最小的距离再乘以11就好,代码如下:
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
char s[205][205];
int dis[205][205],book[205][205];
int mov[4][2]={0,1,1,0,0,-1,-1,0};
int n,m;
struct node
{
    int x,y,step;
}st,ne;
void bfs(int x,int y)
{
    memset(book,0,sizeof(book));//标记数组
    queue<node>q;
    st.x=x;//结构体的运用
    st.y=y;
    st.step=0;
    q.push(st);//把这组数据放到队列里面
    while(!q.empty())//如果队列不为空,就循环
    {
        st=q.front();//把队列第一组数据赋值给st这个结构体
        q.pop();//把首位推出去,删去
        if(s[st.x][st.y]=='@')
        {
            if(dis[st.x][st.y]==0x3f3f3f3f)
                dis[st.x][st.y]=st.step;
            else
                dis[st.x][st.y]+=st.step;
        }
        for(int i=0;i<4;i++)
        {   
            ne.x=st.x+mov[i][0];
            ne.y=st.y+mov[i][1];
            if(ne.x>=0&&ne.x<n&&ne.y>=0&&ne.y<m&&s[ne.x][ne.y]!='#'&&book[ne.x][ne.y]==0)
            {
                ne.step=st.step+1;
                book[ne.x][ne.y]=1;
                q.push(ne);//把ne结构体推入到队列
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        int x1,x2,y1,y2;
        for(int i=0;i<n;i++)
        {
            scanf("%s",s[i]);
            for(int j=0;j<m;j++)
            {
                if(s[i][j]=='Y') x1=i,y1=j;//两个人的坐标
                if(s[i][j]=='M') x2=i,y2=j;
            }
        }
        memset(dis,0x3f3f3f3f,sizeof(dis));
        bfs(x1,y1);
        bfs(x2,y2);
        int ans=0x3f3f3f3f;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(dis[i][j]<ans)
                   ans=dis[i][j];
            }
        }
        printf("%d\n",ans*11);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值