poj 1125 Stockbroker Grapevine ----Floyd算法,有向图

Stockbroker Grapevine
Time Limit:1000MS Memory Limit:10000K
Total Submissions:19896 Accepted:10744

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10


题目大意: 我直接用 输入示例说明吧,

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2    表示 第一行表示一个股票经纪人需要向三个人传消息,第二行表示 第一个人有两个朋友, 向第二个朋友传消息需要 时间4 ,向第三个朋友发消息需要时间 5,第二行表示 第二个人有两个朋友,向第一个人传消息需要时间2,向第三个人传消息需要时间 6,第三行同样。
     求 能够 向所有人都传到消息并且需要的时间最短的人,以及 这个人向某个人传消息所花的最多的时间。
    输出  3 2 。 即表示 让第三个人传消息 所需的时间最短, 他 向其他人传消息最多的一次用了 时间2。
    如果没有人可以 向所有人传递消息,输出 disjoint  
   解题思路: Floyd 算法。 即穷举断点 ,不断更新两点之间的 最小 距离。
                   装态转移方程 map[i,j]:=min{map[i,k]+map[k,j],map[i,j]}        。k表示 穷举得断点。
 
代码:
//Memory: 172 KB		Time: 16 MS
//Language: C++		Result: Accepted
#include<stdio.h>
const int INF=0xFFFFFF;
int map[105][105];  // 有向图
int main()
{
//	freopen("in.txt","r",stdin);
	int n,i,j,k,t,max,sum,minSum,st;
	while(scanf("%d",&n)!=EOF&&n)
	{
		max=0,minSum=INF;
		for(i=0;i<n;i++)
			for(j=0;j<n;j++)
			{
				if(i==j) map[i][j]=0;
				else map[i][j]=INF;    //将两点距离附一个大值 ,视为不通。
			}
		for(i=0;i<n;i++)
		{
			scanf("%d",&t);
			for(j=0;j<t;j++)
			{
				int time,ed;
				scanf("%d%d",&ed,&time);
				map[i][ed-1]=time;
			}
		}
		for(k=0;k<n;k++)          //Floyd算法
			for(i=0;i<n;i++)
				for(j=0;j<n;j++)
				    if(map[i][k]+map[k][j]<map[i][j])          //状态转移
						map[i][j]=map[i][k]+map[k][j];
		for(i=0;i<n;i++)        
		{
			sum=0;
			int tmax=0;
			for(j=0;j<n;j++)
			{
				sum+=map[i][j];
				if(map[i][j]>tmax)
					tmax=map[i][j];
				if(sum>=INF) break;
			}
			if(sum<minSum)       //找最小时间
			{
				st=i;
				minSum=sum;
				max=tmax;          
			}
		}
		minSum==INF ? printf("disjoint\n"): printf("%d %d\n",st+1,max);    //如果最小时间没更新 ,说明没有通路。
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值