hdu 1059 Dividing(二进制转化优化)

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5887    Accepted Submission(s): 1594

Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.

 

Sample Input
 
 
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0

 

Sample Output
 
 
Collection #1: Can't be divided. Collection #2: Can be divided.
 

        此题属于多重背包,数据很大,需要二进制优化,不然超时。优化后直接当做01背包来做,01背包是逆序!

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1059

代码: 

#include <iostream>
#include <stdio.h>
#include <memory.h>
using namespace std;

const int N = 6;
int V, total, sum;
int bag[120005];
int w[15], n[15], v[1005];

void _01_bag()
{
    int i, j;
    memset(bag, 0, sizeof(bag));
    for(i = 0; i < total; i++)
    {
        for(j = sum; j >= v[i]; j--)
        {
            bag[j] = max(bag[j], bag[j-v[i]]+v[i]);
        }
    }
}

int main()
{
    int i, temp, zz = 1;
    while(scanf("%d %d %d %d %d %d", &n[0], &n[1], &n[2], &n[3], &n[4], &n[5]))
    {
        if(n[0] + n[1] + n[2] + n[3] + n[4] + n[5] == 0) break;
        printf("Collection #%d:\n", zz++);
        V = 0;
        for(i = 0; i < N; i++)
        {
            w[i] = i + 1;
            V += w[i]*n[i]; //求总和
        }
        if(V%2 == 1)    //总和是奇数则不能平分
        {
            printf("Can't be divided.\n\n");
            continue;
        }
        sum = V/2; total = 0;
        for(i = 0; i < N; i++)  //二进制压缩为——01背包
        {
            if(n[i] == 0) continue;
            temp = 1;
            while(n[i] > temp)
            {
                v[total++] = temp*w[i]; //将新的值赋给v[]
                n[i] -= temp;
                temp *= 2;
            }
            v[total++] = n[i]*w[i];
        }
        _01_bag();  //用新的v[]数组直接拿来01背包
        if(bag[sum] != sum)
            printf("Can't be divided.\n\n");
        else
            printf("Can be divided.\n\n");
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值