hdu 3033 I love sneakers!(分组背包:每组至少一个)

I love sneakers!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 890    Accepted Submission(s): 381

Problem Description
After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.

There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand.
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice.
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.

 

Input
Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.

 

Output
For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.

 

Sample Input
 
 
5 10000 3 1 4 6 2 5 7 3 4 99 1 55 77 2 44 66

 

Sample Output
 
 
255
 

         此题也是分组背包(每组至少放一个)!!!

      和普通的分组背包(每组至多放一个)不用,看了网上的解题报告,把后面两个循环调转一下就行,至于为什么,我也不知道怎么解释,直接套。

链接:http://acm.hdu.edu.cn/showproblem.php?pid=3033

代码:

#include <iostream>
#include <stdio.h>
#include <memory.h>
using namespace std;

const int INF = 99999999;

int max(int a, int b, int c)
{
    int M;
    M = a > b ? a : b;
    M = M > c ? M : c;
    return M;
}

int c[105], w[105], s[105];
int bag[15][10005];
int N, V, S;

void _gro_bag()
{
    int i, j, k;
    for(i = 1; i <= S; i++)
        for(j = 0; j <= V; j++)
            bag[i][j] = -INF;
    for(i = 1; i <= S; i++)
        for(k = 0; k < N; k++)
            for(j = V; j >= 0; j--)
                if(s[k] == i && j >= c[k])
                    bag[i][j] = max(bag[i][j], bag[i-1][j-c[k]]+w[k], bag[i][j-c[k]]+w[k]);
}

int main()
{
    int i;
    while(scanf("%d %d %d", &N, &V, &S) != EOF)
    {
        for(i = 0; i < N; i++)
            scanf("%d%d%d", &s[i], &c[i], &w[i]);
        _gro_bag();
        if(bag[S][V] < 0) printf("Impossible\n");
        else printf("%d\n", bag[S][V]);
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值