hdu 1045 Fire Net(二分图 or dfs)

 Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2427    Accepted Submission(s): 1380

Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

 

 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.
Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
Sample Input
 
 
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
Sample Output
 
 
5 1 5 2 4
 

             题目大意:给你一幅图,再给你一些点,这些点的上下左右不能再放其他点,除非有墙隔着,问最多可以放多少个这样的点。

         首先这道题一看,明显用dfs就可以搞定,但是现在在看二分图专题,有这道题,然后查了一下,原来还真能用二分图,方法非常的巧妙啊!只要建了图就能够轻松解决,效率比dfs高很多!

         重点是建图:要建两幅图,行一幅,列一幅,然后map[行][列]建立关系,这样就建完了。最后就是用二分图匈牙利算法秒杀!

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1045

代码:

#include <iostream>
#include <stdio.h>
#include <memory.h>
using namespace std;

const int N = 15;
int a[N][N], b[N][N], pre[N];
char ch[N][N];
bool visit[N][N], map[N][N], flag[N];
int n, ans1, ans2;

void bulid()
{
    int i, j, k;
    memset(visit, false, sizeof(visit));
    ans1 = 1;
    for(i = 1; i <= n; i++)     //行
    {
        for(j = 1; j <= n; j++)
        {
            if(!visit[i][j] && ch[i][j] != 'X')
            {
                k = j;
                while(k <= n && ch[i][k] != 'X')
                {
                    a[i][k] = ans1;
                    visit[i][k] = true;
                    k++;
                }
                ans1++;
            }
        }
    }
    memset(visit, false, sizeof(visit));
    ans2 = 1;
    for(i = 1; i <= n; i++)     //列
    {
        for(j = 1; j <= n; j++)
        {
            if(!visit[i][j] && ch[i][j] != 'X')
            {
                k = i;
                while(k <= n && ch[k][j] != 'X')
                {
                    b[k][j] = ans2;
                    visit[k][j] = true;
                    k++;
                }
                ans2++;
            }
        }
    }
    for(i = 1; i <= n; i++)
    {
        for(j = 1; j <= n; j++)
        {
            map[ a[i][j] ][ b[i][j] ] = true;
        }
    }
}

int find(int cur)
{
    int i;
    for(i = 1; i < ans2; i++)
    {
        if(map[cur][i] && !flag[i])
        {
            flag[i] = true;
            if(pre[i] == -1 || find(pre[i]))
            {
                pre[i] = cur;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    int i, j, sum;
    while(scanf("%d", &n), n)
    {
        for(i = 1; i <= n; i++)
            for(j = 1; j <= n; j++)
                cin >> ch[i][j];
        memset(a, 0, sizeof(a));
        memset(b, 0, sizeof(b));
        memset(map, 0, sizeof(map));
        memset(pre, -1, sizeof(pre));
        bulid();
        sum = 0;
        for(i = 1; i < ans1; i++)
        {
            memset(flag, 0, sizeof(flag));
            sum += find(i);
        }
        printf("%d\n", sum);
    }

    return 0;
}

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值