hdu1016Prime Ring Problem

http://acm.hdu.edu.cn/showproblem.php?pid=1016

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11874Accepted Submission(s): 5381


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input
 
  
68

Sample Output
 
  
Case 1:1 4 3 2 5 61 6 5 2 3 4Case 2:1 2 3 8 5 6 7 41 2 5 8 3 4 7 61 4 7 6 5 8 3 21 6 7 4 3 8 5 2

Source

Recommend
JGShining
#include<stdio.h>
#include<string.h>
int a[22],flag[22];
int pos,n;
int prime[15]={3,5,7,11,13,17,19,23,29,31,37};
int isprime(int num)
{
int i;
for(i=0;i<11;i++)
if(num==prime[i]) return 1;
return 0;
}
void dfs(int pos)
{
int i;
if(pos==n&&isprime(a[n]+a[1]))
{
for(i=1;i<n;i++)
printf("%d ",a[i]);
printf("%d\n",a[n]);
return;
}
if(pos>=n) return;
for(i=2;i<=n;i++)
{
if(flag[i]==0&&isprime(a[pos]+i))
{
a[++pos]=i;flag[i]=1;
dfs(pos);
--pos;flag[i]=0;//这是唯一需要注意的地方 千万要将其状态转换回来
}
}
}
int main()
{
int cnt=0;
while(scanf("%d",&n)!=EOF)
{
cnt++;pos=1;
printf("Case %d:\n",cnt);
memset(flag,0,sizeof(flag));
a[1]=1;flag[1]=1;
dfs(pos);
printf("\n");
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值