Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
Sample Input
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
Sample Output
3 4 6
动态规划入门题:
dp[j] = max(dp[j], dp[j-k]+a[i][k]);
代码:
#include<stdio.h>
#include<string.h>
#define max 205
int main()
{
//freopen("in.txt","r",stdin);
int i,j,k,n,m,a[max][max],dp[max];
while(scanf("%d%d",&n,&m),n||m)
{
memset(dp,0,sizeof(dp));
for(i=1; i<=n; i++)
for(j=1; j<=m; j++)
scanf("%d",&a[i][j]);
for(i=1; i<=n; i++)
for(j=m; j>=1; j--)
for(k=1; k<=j; k++)
if(dp[j]<dp[j-k]+a[i][k])dp[j]=dp[j-k]+a[i][k];
printf("%d\n",dp[m]);
}
return 0;
}