ACboy needs your help(分组背包)

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8901    Accepted Submission(s): 4902

Problem Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

Sample Input

2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0

Sample Output

3 4 6

Source

HDU 2007-Spring Programming Contest

Recommend

lcy

 

乍一看好像很难的样子,其实仔细想想很简单,这种问题完全可以用01背包解决。

对于分组背包,可以这样想:虽然分成很多组,但是每一组只能选一个,或者不选

这样来看,完全就是01背包问题。

for(int i = 1;i<=Group;i++)///组数
    for(int j = Volume;j>=1;j--)///容积
        for(int k = 1;k<=n;k++)///每组中的物体
            dp[j] = max(dp[j - wight[i][k]] + value[i][k], dp[j]);
///当前组中取不取,取的话取哪一个物体,

 

 

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 1e2+7;
int A[maxn][maxn];
int dp[maxn];
int n,m;
int main(){
    while(cin>>n>>m && n && m){///course,days
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                scanf("%d",&A[i][j]);///spend j days in i-th course will Get
        for(int Grp=1;Grp<=n;Grp++){///n种课
            for(int v=m;v+1;v--){///一共m天
                for(int i=1;i<=v;i++)///对于当前的第Grp种课来说,取几天[0,v]比较好
                    dp[v] = max(dp[v],dp[v-i]+A[Grp][i]);
            }
        }
        printf("%d\n",dp[m]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值